イントロダクション

Universal Viewer
このアプリケーションは、広範囲のファイル形式に対応している高度なファイルビューワです。
実装されている表示モードと対応するファイル形式は以下の通りです:

  • テキスト, バイナリ, 16進, Unicode: のすべてのファイル、サイズ制限なし (4GB を超えるサイズでも許容します)
  • RTF/UTF-8: RTF/UTF-8 でエンコードされたファイル
  • イメージ: すべての一般的な画像形式: BMP JPG GIF PNG TGA TIFF...
    また、外部ビューワ、IrfanView / XnView が対応するすべての形式
  • マルチメディア: MS Windows Media Player で対応するすべての形式: AVI MPG WMV MP3...
  • インターネット: MS Internet Explorer で対応するすべての形式: HTML XML DOC XLS...
  • プラグイン: すべての Total Commander Lister プラグインに対応。
  • MS Office: MS Office のすべてのファイル形式(インストール環境が必須): DOC DOCX XLS PPT...
  • テキスト変換機能: プレーンテキストとして表示可能な形式: DOC DOCX PDF PPT ODT...

このアプリケーションは、Unicode との完全な互換性 を持つため、 Windows エクスプローラ のコンテキストメニューに 統合することが出来ます。どこからでも呼び出すことが出来ます: ファイルを右クリックして"Universal Viewer" 選択するだけです。 また、他の有名な ファイラと統合 して使用することが出来ます。

基本的に、Universal Viewer は、Total Commander Lister と同等の機能を持ちます。 それに、Lister と比較するといくつかの利点があります:

  • いくつかのプラグインの機能を内蔵: イメージ/マルチメディア/ウェブページ等の表示
  • 複数のコードページに対応: ANSI、OEM、EBCDIC、ISO、KOI8、Mac etc...
  • 対応するテキスト変換: DOC, DOCX, ODT, PDF etc.
  • ユーザツールの対応
  • ツールバー、ステータスバー、その他のインターフェースの改良
  • ファイルの変更後の自動再読み込み (オプションの"追随")
  • 行番号の表示
  • 印刷不可文字の表示
  • Unicode/16進モードの結合(Unicodeモードを二回コール)
  • より最新の正規表現検索ライブラリ
  • 印刷プレビュー
  • EXIF ビューワ
  • NavPanel アドオンにエクスプローラのインタフェースを追加

追加のウェブリンク:

  • 推奨されるリスタープラグイン
  • ソースコードページ
  • 構成ファイルの再配置用ツール
  • リスタープラグインの既知の問題点


NavPanel - アドオン

ナビゲーションパネル アドオンは、 Universal Viewer の F4 キーで表示されます (デフォルトショートカット) エクスプローラ風のインターフェースでフォルダ、及びファイルを閲覧することができます。
パネルで選択されたファイルは、ビューワ本体で表示され、表示されている ファイルは
パネル内では強調表示されます。

NavPanel で使用できる操作:

  • "ファイル -- リネーム/ フォルダにコピー/ フォルダに移動" コマンド
  • "ファイル -- E-メールを送信" コマンド
  • ユーザツールの実行
  • テキスト変換機能の実行
  • MS Office コントロールの登録

    NavPanel は、15 日間試用可能な シェアウェアです。


使用許諾契約: フリーバージョン

この使用許諾契約は、 Universal Viewer Free ("アプリケーション")に適用されます。

このアプリケーションは フリーウェア として配布されます 概要:

  1. このアプリケーションのすべての著作権は、著作者である 　Alexey Torgashin が所有します。

  2. 作者は、いかなる目的 (個人、商用) に関わらず、このソフトウェアを 制限なく、無料で使用する権利をあなたに与えます。

  3. アプリケーションは、 現状のままの状態で配布されます。いかなる種類の補償もありません。 使用者は、すべて本人の責任において使用します。 このソフトウェアの使用により発生した データの損失、また、試用期間中に発生した利益の損失、その他のいかなる種類の損失、損害 についても、作者は一切の責任を負わないものとします。


使用許諾契約: プロバージョン

注意: ロシア語を使用するユーザーへの追加ライセンスについては ロシア語ヘルプファイルにおいて提供されます

この使用許諾契約は、 Universal Viewer Pro ("アプリケーション")に適用されます。

このアプリケーションは シェアウェア として配布されます。
概要:

  1. このアプリケーションのすべての著作権は、著作者である 　Alexey Torgashin が所有します。

  2. 15 日間の試用期間は、ソフトウェアのすべての機能を使用できます。 試用期間以降も、アプリケーションを継続して使用したい場合は、 登録していただく必要があります。

  3. 登録する為には、登録キーを購入する必要があります。 キーの購入は、アプリケーションのホームページにある 登録用フォームに必要事項を記入してください。

  4. アプリケーションは、 現状のままの状態で配布されます。いかなる種類の補償もありません。 使用者は、すべて本人の責任において使用します。 このソフトウェアの使用により発生した データの損失、また、試用期間中に発生した利益の損失、その他のいかなる種類の損失、損害 についても、作者は一切の責任を負わないものとします。


プロバージョンの登録

Universal Viewer プロバージョンはシェアウェアです. 評価期間である15日間は、アプリケーションのすべての機能を使用できますが、 評価期間以降、継続して使用する場合は、登録する必要があります。

登録するには、アプリケーションの ホームページ にある登録フォームを利用してください。 登録料は $23 です

登録の完了後に、あなたのメール宛に、登録キーが送られます。 (キーを受け取るまで、2 - 3日 かかることがあります)
受け取ったキーを、メニュー ("ヘルプ -- 登録") から入力してください。


FAQ - よくある質問

Q1: Universal Viewer を他のファイラに統合する方法
Q2: DOC/XLS, ODT/ODS or PDF ファイルを表示出来ません...
Q3: ファイルサイズの制限はどれぐらいですか?
Q4: HTMLページのリンクを開く際のセキュリティに関心があります?
Q5: Flashアニメーションを全画面で表示できませんか?
Q6: UTF-8 エンコードされたテキストで、表示できないものがありますが?
Q7: Word/Excel ドキュメントが、たまに新規ウィンドウで開かれてしまう事があります...
Q8: WMP 6.4 コントロールの外観の変更方法
Q9: IrfanView/XnView からイメージを取得した時に、アニメーションが機能しません...
Q10: ファイル名に Unicode を使用することは出来ますか?

Q1: Universal Viewer を他のファイラに統合する方法

A:

  • Total Commander

    "設定 -- オプション -- 編集/表示 タブ", "外部ビューワ"にチェックしてパスを入力 Viewer.exe into フィールドを "デフォルト:". パスにスペースが含まれる場合は、最初に、2重引用符で囲んでください。

    Viewer は F3 キーに割り当てられています。

    また、TC ファイルパネルに、Viewer を呼び出すツールバーボタンを追加することが出来ます。 TC ツールバーの開いているスペースに、Vewer.exe をドラッグしてください。 追加された新しいボタンを右クリックして、変更を選択、そしてパラメータフィールドに "@%L" (引用符付) を入力してください。

  • FAR Manager

    "オプション -- ビューワ設定" と "Alt+F3" にチェック "Viewer command:" フィールドの追加マクロに Viewer.exe のパスを入力
    "C:\Program Files\Universal Viewer\Viewer.exe" "!\!.!"

    ビューワは、Alt+F3 キーに割り当てられます。

    また、FAR ファイルパネルに、UV で選択したファイルリストを渡すことが出来ます。 "Viewer command:" フィールドの値を以下のように変更します:
    "C:\Program Files\Universal Viewer\Viewer.exe" "@!@AF!"

  • FreeCommander

      "Extras -- Settings -- Programs tab"、の "External viewer" フィールドに Viewer.exe 　のパスを入力します。

      ビューワは、Shift+F3 キーに割り当てられます。

      F3 キーにビューワを割り当てる場合は、"Extras -- Define shortcuts" ダイアログ 　の "File - View external" コマンドで F3 ショートカットに設定します

  • SpeedCommander

    "Extra -- Settings" ダイアログ, "Advanced -- Applications & Internet" タブの, "Viewer:"フィールドにパスを入力、または参照ボタンから Viewer.exe を選択してください。

    Viewerは、F3 キーに割り当てられます。

Q2: DOC/XLS, ODT/ODS または PDF ファイルを表示することが出来ません。Viewer では、空白ページが表示されます。 どうすれば修正できますか?

A1:

DOC/XLS を表示する為には、以下のどれかをインストールする必要があります:

  • Microsoft Office
  • Lister plugin for DOC/XLS
ODT/ODS/ODP を表示する為には、以下のどれかをインストールする必要があります:
  • OpenOffice.org
  • Lister plugin for ODT/ODS
PDF を表示する為には、以下のどれかをインストールする必要があります:
  • Adobe Reader
  • Foxit Reader
  • Lister plugin for PDF

A2: 最初の回答(Officeアプリケーションをインストールする) では解決されず、インターネットモード時に空白ページウィンドウが 開いてしまう場合は、隠しオプションの "WebAcceptAllFiles (ヘルプの " 隠しオプション " を参照)" を試してみてください。

Q3: ファイルサイズの制限はどれぐらいでしょうか?

A: UV では、テキスト/バイナリ/16 進/Unicode モードで、どんなサイズのファイルも開けます。 また、UV はメモリにファイル内容のすべてではなく、少量(約120-180KB)のデータを保持する ため、前述した表示モードで、巨大なファイルのすばやいスクロールが可能です。

ただし、RTF/UTF-8 モードと(通常の)プラグインモード時は、巨大ファイルを開くことは出来ません。 RichEdit コントロール、及びプラグインの大部分が、ファイル内容のすべてを読み込もうとする為、 動作が非常に遅くなり 失敗してしまいます。

Q4: Universal Viewer でローカルのHTMLページのリンクを開く時に、何か安全上注意することは ありますか? 何故この質問をするのかというと、最近は絶えずブラウザのセキュリティフローに関する 情報を耳にするためです。

A: UV のセキュリティ上の配慮は、基本的に IE (現在の設定の)と同じものです。 UV では、ウェブコントロールのコードと設定に現在の MSIE のものを使用しています。

MSIE には欠点があります。そしてそれであなたがオンラインページを開きたくないなら, UV でリンクを開くべきではありません。その場合は、オプション設定で防止することを お勧めします。"表示 / インターネット / オフラインモード", から、オンラインコンテンツを UV で開かないように出来ます。ただし、MSIE の設定で、リンクを新しいウィンドウで開くように 設定されている場合は、このオプションは、有効ではありません。

Q5: Flash アニメーションを全画面で再生できませんか?

A: デフォルトでは、Flash アニメーションはインターネットモード MSIE ウィンドウで 再生されます。Flash ピクチャサイズは以下の方法で変更することが出来ます:

  • Windows Media Player を使用する場合は、設定ダイアログを開いて、"一般" タブの "ファイル拡張子" の"インターネット" と "メディア" 欄に拡張子 "swf" を記載してください。そして、"拡張" タブの マルチメディアモード のところを "Windows Media Player 9.0" にしてください。
  • リスタープラグインのひとつを使用します.

Q6: UTF-8 エンコードで表示できないテキストがありますが?

A: 旧バージョン(1.5.9.0以下) では、UTF-8 署名を要求するようにしていましたが、 最新バージョンでは、これを中止しました。以下に注意してください:

  • Windows 9x 以前のものは UTF-8 に対応していません
  • UTF-8 テキストの署名は自動検出されないので、必要な場合は、手動で "RTF/UTF-8"表示モード の設定をする必要があります。

Q7: Word/Excel ドキュメントが、たまに新規ウィンドウで開かれてしまいます ...

A: これは、MS Office の既知のバグです。修正したい場合は、以下の手順で .REG ファイルを作成してください。 最初に空のテキストファイルを新規作成します。そのテキストに、下に書いてある値を コピーして、ファイル名を "Fix.reg" にリネーム後、ダブルクリックしてください:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.8]
"BrowserFlags"=dword:80000024

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.RTF.8]
"BrowserFlags"=dword:80000024

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.Document.12]
"BrowserFlags"=dword:80000024

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Word.DocumentMacroEnabled.12]
"BrowserFlags"=dword:80000024

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.8]
"BrowserFlags"=dword:80000A00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.Sheet.12]
"BrowserFlags"=dword:80000A00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.SheetMacroEnabled.12]
"BrowserFlags"=dword:80000A00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Excel.SheetBinaryMacroEnabled.12]
"BrowserFlags"=dword:80000A00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.Show.8]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.Show.12]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.ShowMacroEnabled.12]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShow.8]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShow.12]
"BrowserFlags"=dword:800000A0

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\PowerPoint.SlideShowMacroEnabled.12]
"BrowserFlags"=dword:800000A0

Q8: WMP 6.4 コントロールの外観はどうやって変更するのでしょうか?

A: Windows Media Player 6.4 コントロールを、WMP 9.0 のような 外観に変更する方法は、(WMP 9.0+ があなたのシステムにインストールされている 必要があります) 以下の .REGファイルを作成して、適用してください:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ShimInclusionList\VIEWER.EXE]

変更を元に戻す場合は、以下の .REGファイルを作成して、適用します:

REGEDIT4

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\ShimInclusionList\VIEWER.EXE]

Q9: IrfanView/XnView からイメージを取得した時に、アニメーションが機能しません...

A: IrfanView/XnView では、BMP をアプリケーションに送ます。 そして、BMP はアニメーションには対応していません。 その為、アニメーション GIF 等を表示する場合は、内部のライブラリを使用する必要があります。 (ヒント: キー '4' で、内部ライブラリと IrfanView/XnView を切り替えることが出来ます)

Q10: ファイル名に Unicode を使用することは出来ますか?

A:

  • Unicode 名のフォルダにはアプリケーションをインストール しないでください。(ANSI 名を想定しています)
  • また以下のプラグインは Unicode名に対応していないかもしれません: IJL15.dll, IrfanView, 　　これは、あなたの OS が、Unicode の名前を読み込む時にショートネーム(8.3) 　　を使用していることによります。 　　あなたの OS がショートネームを使用しているかどうか確認したい時は、フォルダを "cmd.exe" 　　(コマンドプロンプト)で開いて、"dir /x" を実行してください。 　　すべての Unicode名のショートネームが表示されます。


Plugins usage

プラグインの使用方法

インストール

.zip / .rar アーカイブからのプラグインのインストール :

  • UV を起動して "オプション -- プラグイン設定" ダイアログの "追加..." をクリック して、"シングルプラグインファイル" をチェックします。 "..." ボタンを押して 開いたダイアログから、プラグイン .wlx ファイルを開いてください。
プラグインアーカイブに"pluginst.inf"が含まれる場合:
  • UVでアーカイブをそのまま開いてください。確認後、自動的にインストールされます。
注意: インストールした新しいプラグインが、前回と違う名前になっていた場合、 古いファイルに正確に上書きされない可能性があります。そのような時は、手動で旧プラグインを削除してください。

最適化

プラグインの最適化について(任意設定).. いくつかのプラグインは、デフォルトで設定 の可能なものがあります。 例えば ICLView プラグインは デフォルトの設定では、拡張子.DLL が含まれていません。 これは、"プラグインの設定" ダイアログで "構成設定..." を押して、検出される文字列 を見る事で、そのプラグインでデフォルトで開かれるファイルの種類 を確認する事が出来ます。 文字列が空白である場合は、プラグインが対応するファイルを内容で 検出しているということになるかもしれません。

以下のような文字列が検出されるとおもいます:

  • フォームのファイル拡張子リスト:
    EXT="TXT" | EXT="DOC" | EXT="RTF"
  • "FORCE" リザーブワード、拡張子なし:
    EXT="TXT" | FORCE
    この単語は、未知のファイル形式を開く時に 強制的にプラグインで開く時に使用します。(" 7 " キー).
  • フォームのファイル拡張子リスト:
    EXT:TXT,DOC,RTF
    EXT:TXT FORCE
    この特殊ワード "FORCE" は、行末のスペースの後に記述されている必要があります。

使用方法

  • プラグインがアクティブな状態で、" 7 " キーを繰り返し 押す事で、現在のファイルに適切なプラグインに切り替える事が出来ます。
  • 現在使用しているプラグインを確認したい場合はウィンドウのキャプションを 見てください、プラグイン名は括弧で囲まれて表示されます。


コマンドライン・パラメータ

アプリケーションは、以下のパラメータを使用出来ます:

  • Viewer.exe FileName [ 任意のパラメータ ]
  • Viewer.exe FolderName [ 任意のパラメータ ]
  • Viewer.exe @FileList [ 任意のパラメータ ]
  • Viewer.exe @@FolderName [ 任意のパラメータ ]

上記のパラメータの意味:

FileName 起動時に開くファイル名:
名前に空白が含まれる場合は、二重引用符("")で囲む必要があります。
FolderName (VisualDirSizeなどの)プラグインで起動時に開くフォルダ名。
このフォルダはナビゲーションパネルでも開かれます。
注意: 名前に空白が含まれる場合は、二重引用符("")で囲んでください。
@@FolderName "ファイル -- 次のファイル/ 前のファイル" コマンドを使用して 起動時に読み込むフォルダを指定することができます。 合計ファイル数は、括弧([])で囲まれてキャプションに表示されます。 この方法で複数のメディアファイルを開いた場合は、順次再生されます(再生リストモード).
注意: 名前に空白が含まれる場合は、二重引用符("")で囲んでください。
FileList いくつかの開くファイル名のリストを含む、一時テキストファイルの名前 :
読み込み完了後に、このファイルは削除されます。 ファイルの合計数は、UV のウィンドウキャプション部に、括弧つきで表示されます。 この方法で、メディアファイルを開くと、それらは連続的に再生されます (再生リストモード).
任意のパラメータ
/Pos=Value ファイルのスクロール位置を指定 :
値:
  • 数字: 絶対位置オフセット. テキスト/インターネットモード時のみ有効
  • 数字+文字 'p': 相対位置、パーセントで指定 テキスト/インターネット/プラグインモードで有効です。
  • 数字+文字 'n': 行番号を指定、 テキストモードでのみ有効です。
/P=Left,Top,Width,Height ウィンドウの初期位置、サイズの指定をする場合は、 Left, Top, Width, Height の順番で有効な値を 指定してください。また、リストの最後はスキップする ことも出来ます。例:/P=Left,Top でウィンドウの位置のみ指定されます。
/Print 開かれている文書を印刷して終了します。
/Mode=Value 初期表示モードの指定 (無効で自動検出).
利用可能な値:
  • 1: テキスト
  • 2: バイナリ
  • 3: 16進
  • 4: イメージ/マルチメディア
  • 5: インターネット/Office
  • 6: Unicode
  • 7: プラグイン
  • 8: RTF/UTF-8


構成ファイル

アプリケーションには、いくつかの構成ファイルがあります:

  • Viewer.ini -- メイン構成ファイル;
  • ViewerHistory.ini -- 様々な履歴: ウィンドウ位置, 検索文字列 その他;
  • lsplugin.ini -- リスタープラグインの構成設定

これらのファイルは以下の位置から検索されます:

  1. 最優先 : UV フォルダ - Viewer.ini ファイルが存在する場合;
  2. 以下のレジストリに保管された位置 "HKEY_CURRENT_USER\Software\UniversalViewer";
  3. 以下のレジストリに保管された位置 "HKEY_LOCAL_MACHINE\Software\UniversalViewer";
  4. 優先度低: デフォルト位置、以下の通り:
    • Windows Vista: "%AppData%\ATViewer" フォルダ;
    • Windows XP と その他のシステム: UV フォルダ.

尚、アプリケーションの portable 版 を作成する場合は、 Viewer.ini ファイルをアプリケーションフォルダに置く必要があります。.


隠しオプション

このプログラムには、設定ダイアログでは変更できない " 隠し " オプションが存在します。 それらの設定を変更する場合は、Viewer.ini ファイルを手動で編集してください。 UV コマンドの "オプション -- 拡張 -- 構成ファイルを直接編集" を選択して、編集します。 また、ファイルの変更後にプログラムを再起動する必要があります。

[オプション] セクション
FileNextMsg | "ファイル -- 次/前のファイル"コマンド: 0 に設定すると、ディレクトリの最初/最後の時に出るメッセージを無効にします。
FileSkipHidden | "ファイル -- -- 次/前のファイル"コマンド: 0 に設定すると、ディレクトリにある隠しファイルのスキップを無効化します。
FileMoveDelay | "ファイル -- リネーム / フォルダに移動" コマンド: ファイルを移動、または閉じるまでの遅延時間 (ミリ秒, デフォルト値= 800) PDFファイルを移動する場合は、より多くの時間が必要になります。
StatusUrlWidth | ステータスバーパネルのURL/コードページの表示幅(デフォルト値 = 約300 px).
ModeUndetected | ファイル形式が不明な場合のモードを指定します。デフォルト値は 1 (テキストモード)になっています。 そのほかのモードは、2 (バイナリ)、3 (十六進)、8 (RTF-UTF8) を使用することが出来ます。
ModesDisabled | これはモード番号のリストです (1 から 8, スペース区切り), モードの自動検出プロシージャに使用されなくなります。 例えば、リストで "5 7 8" とした場合, インターネットプラグインと RTF/UTF-8 モード はモード自動検出プロシージャに使用されません。
SearchNoCfm | 1 に設定すると、"検索文字が見つかりません" ダイアログを表示する代わりに ビープ音を鳴らします。 更に、ビープ音の後に F3 を押すことで、ドキュメントの最初/最後から検索を繰り返します。
[Text] section
MaxClip | テキスト/バイナリ/Hex/Unicode モード時に、クリップボードにコピーする時のデータ サイズの最大値を設定します。デフォルト値は 16 (Mb)です。この設定で、コピー前のアクシデントや 容量の大きいブロックを選択した時の "hanging" を防止できます。
[Media] section
AutoAdv | UV を、@FileList パラメータで実行中に、ファイルリスト内に複数のメディアクリップが 存在する時、デフォルトではこれらは、"再生リストモード": で取り扱われます。 ここを 0 に設定すると、"再生リストの自動進捗" が無効化され、手動で"ファイル --次のファイル" コマンドを実行することになります。
[ショートカット] セクション
MenuItemID 特定のメニューアイテムのショートカットの変更
現在は、オプションダイアログからこれらの設定が可能ですが、オプションダイアログで、割り当てたい キーが見つからない(例: Esc と BackSpace には割り当てられていません) 時は、手動でパラメータを編集 することが出来ます。
  • 利用可能なキー: Space BkSp Tab Esc Enter PgUp PgDn Home End Left Right Up Down Ins Del A...Z F1...F12
  • 利用可能な修飾キー: Shift+ Ctrl+ Alt+


PCRE Regular Expressions Syntax

This page is part of the PCRE HTML documentation. It was generated automatically from the original man page. If there is any nonsense in it, please consult the man page, in case the conversion went wrong.

  • PCRE REGULAR EXPRESSION DETAILS
  • BACKSLASH
  • CIRCUMFLEX AND DOLLAR
  • FULL STOP (PERIOD, DOT)
  • MATCHING A SINGLE BYTE
  • SQUARE BRACKETS AND CHARACTER CLASSES
  • POSIX CHARACTER CLASSES
  • VERTICAL BAR
  • INTERNAL OPTION SETTING
  • SUBPATTERNS
  • NAMED SUBPATTERNS
  • REPETITION
  • ATOMIC GROUPING AND POSSESSIVE QUANTIFIERS
  • BACK REFERENCES
  • ASSERTIONS
  • CONDITIONAL SUBPATTERNS
  • COMMENTS
  • RECURSIVE PATTERNS
  • SUBPATTERNS AS SUBROUTINES
  • CALLOUTS

PCRE REGULAR EXPRESSION DETAILS

The syntax and semantics of the regular expressions supported by PCRE are described below. Regular expressions are also described in the Perl documentation and in a number of books, some of which have copious examples. Jeffrey Friedl's "Mastering Regular Expressions", published by O'Reilly, covers regular expressions in great detail. This description of PCRE's regular expressions is intended as reference material.

The original operation of PCRE was on strings of one-byte characters. However, there is now also support for UTF-8 character strings. To use this, you must build PCRE to include UTF-8 support, and then call pcre_compile() with the PCRE_UTF8 option. How this affects pattern matching is mentioned in several places below. There is also a summary of UTF-8 features in the section on UTF-8 support in the main pcre page.

The remainder of this document discusses the patterns that are supported by PCRE when its main matching function, pcre_exec(), is used. From release 6.0, PCRE offers a second matching function, pcre_dfa_exec(), which matches using a different algorithm that is not Perl-compatible. The advantages and disadvantages of the alternative function, and how it differs from the normal function, are discussed in the pcrematching page.

A regular expression is a pattern that is matched against a subject string from left to right. Most characters stand for themselves in a pattern, and match the corresponding characters in the subject. As a trivial example, the pattern

  The quick brown fox
matches a portion of a subject string that is identical to itself. When caseless matching is specified (the PCRE_CASELESS option), letters are matched independently of case. In UTF-8 mode, PCRE always understands the concept of case for characters whose values are less than 128, so caseless matching is always possible. For characters with higher values, the concept of case is supported if PCRE is compiled with Unicode property support, but not otherwise. If you want to use caseless matching for characters 128 and above, you must ensure that PCRE is compiled with Unicode property support as well as with UTF-8 support.

The power of regular expressions comes from the ability to include alternatives and repetitions in the pattern. These are encoded in the pattern by the use of metacharacters, which do not stand for themselves but instead are interpreted in some special way.

There are two different sets of metacharacters: those that are recognized anywhere in the pattern except within square brackets, and those that are recognized in square brackets. Outside square brackets, the metacharacters are as follows:

  \      general escape character with several uses
  ^      assert start of string (or line, in multiline mode)
  $      assert end of string (or line, in multiline mode)
  .      match any character except newline (by default)
  [      start character class definition
  |      start of alternative branch
  (      start subpattern
  )      end subpattern
  ?      extends the meaning of (
         also 0 or 1 quantifier
         also quantifier minimizer
  *      0 or more quantifier
  +      1 or more quantifier
         also "possessive quantifier"
  {      start min/max quantifier
Part of a pattern that is in square brackets is called a "character class". In a character class the only metacharacters are:
  \      general escape character
  ^      negate the class, but only if the first character
  -      indicates character range
  [      POSIX character class (only if followed by POSIX syntax)
  ]      terminates the character class
The following sections describe the use of each of the metacharacters.

BACKSLASH

The backslash character has several uses. Firstly, if it is followed by a non-alphanumeric character, it takes away any special meaning that character may have. This use of backslash as an escape character applies both inside and outside character classes.

For example, if you want to match a * character, you write \* in the pattern. This escaping action applies whether or not the following character would otherwise be interpreted as a metacharacter, so it is always safe to precede a non-alphanumeric with backslash to specify that it stands for itself. In particular, if you want to match a backslash, you write \\.

If a pattern is compiled with the PCRE_EXTENDED option, whitespace in the pattern (other than in a character class) and characters between a # outside a character class and the next newline are ignored. An escaping backslash can be used to include a whitespace or # character as part of the pattern.

If you want to remove the special meaning from a sequence of characters, you can do so by putting them between \Q and \E. This is different from Perl in that $ and @ are handled as literals in \Q...\E sequences in PCRE, whereas in Perl, $ and @ cause variable interpolation. Note the following examples:

  Pattern            PCRE matches   Perl matches

  \Qabc$xyz\E        abc$xyz        abc followed by the contents of $xyz
  \Qabc\$xyz\E       abc\$xyz       abc\$xyz
  \Qabc\E\$\Qxyz\E   abc$xyz        abc$xyz
The \Q...\E sequence is recognized both inside and outside character classes.

Non-printing characters

A second use of backslash provides a way of encoding non-printing characters in patterns in a visible manner. There is no restriction on the appearance of non-printing characters, apart from the binary zero that terminates a pattern, but when a pattern is being prepared by text editing, it is usually easier to use one of the following escape sequences than the binary character it represents:

  \a        alarm, that is, the BEL character (hex 07)
  \cx       "control-x", where x is any character
  \e        escape (hex 1B)
  \f        formfeed (hex 0C)
  \n        newline (hex 0A)
  \r        carriage return (hex 0D)
  \t        tab (hex 09)
  \ddd      character with octal code ddd, or backreference
  \xhh      character with hex code hh
  \x{hhh..} character with hex code hhh..
The precise effect of \cx is as follows: if x is a lower case letter, it is converted to upper case. Then bit 6 of the character (hex 40) is inverted. Thus \cz becomes hex 1A, but \c{ becomes hex 3B, while \c; becomes hex 7B.

After \x, from zero to two hexadecimal digits are read (letters can be in upper or lower case). Any number of hexadecimal digits may appear between \x{ and }, but the value of the character code must be less than 256 in non-UTF-8 mode, and less than 2**31 in UTF-8 mode (that is, the maximum hexadecimal value is 7FFFFFFF). If characters other than hexadecimal digits appear between \x{ and }, or if there is no terminating }, this form of escape is not recognized. Instead, the initial \x will be interpreted as a basic hexadecimal escape, with no following digits, giving a character whose value is zero.

Characters whose value is less than 256 can be defined by either of the two syntaxes for \x. There is no difference in the way they are handled. For example, \xdc is exactly the same as \x{dc}.

After \0 up to two further octal digits are read. If there are fewer than two digits, just those that are present are used. Thus the sequence \0\x\07 specifies two binary zeros followed by a BEL character (code value 7). Make sure you supply two digits after the initial zero if the pattern character that follows is itself an octal digit.

The handling of a backslash followed by a digit other than 0 is complicated. Outside a character class, PCRE reads it and any following digits as a decimal number. If the number is less than 10, or if there have been at least that many previous capturing left parentheses in the expression, the entire sequence is taken as a back reference. A description of how this works is given later, following the discussion of parenthesized subpatterns.

Inside a character class, or if the decimal number is greater than 9 and there have not been that many capturing subpatterns, PCRE re-reads up to three octal digits following the backslash, ane uses them to generate a data character. Any subsequent digits stand for themselves. In non-UTF-8 mode, the value of a character specified in octal must be less than \400. In UTF-8 mode, values up to \777 are permitted. For example:

  \040   is another way of writing a space
  \40    is the same, provided there are fewer than 40 previous capturing subpatterns
  \7     is always a back reference
  \11    might be a back reference, or another way of writing a tab
  \011   is always a tab
  \0113  is a tab followed by the character "3"
  \113   might be a back reference, otherwise the character with octal code 113
  \377   might be a back reference, otherwise the byte consisting entirely of 1 bits
  \81    is either a back reference, or a binary zero followed by the two characters "8" and "1"
Note that octal values of 100 or greater must not be introduced by a leading zero, because no more than three octal digits are ever read.

All the sequences that define a single character value can be used both inside and outside character classes. In addition, inside a character class, the sequence \b is interpreted as the backspace character (hex 08), and the sequence \X is interpreted as the character "X". Outside a character class, these sequences have different meanings (see below).

Generic character types

The third use of backslash is for specifying generic character types. The following are always recognized:

  \d     any decimal digit
  \D     any character that is not a decimal digit
  \s     any whitespace character
  \S     any character that is not a whitespace character
  \w     any "word" character
  \W     any "non-word" character
Each pair of escape sequences partitions the complete set of characters into two disjoint sets. Any given character matches one, and only one, of each pair.

These character type sequences can appear both inside and outside character classes. They each match one character of the appropriate type. If the current matching point is at the end of the subject string, all of them fail, since there is no character to match.

For compatibility with Perl, \s does not match the VT character (code 11). This makes it different from the the POSIX "space" class. The \s characters are HT (9), LF (10), FF (12), CR (13), and space (32). (If "use locale;" is included in a Perl script, \s may match the VT character. In PCRE, it never does.)

A "word" character is an underscore or any character less than 256 that is a letter or digit. The definition of letters and digits is controlled by PCRE's low-valued character tables, and may vary if locale-specific matching is taking place (see "Locale support" in the pcreapi page). For example, in the "fr_FR" (French) locale, some character codes greater than 128 are used for accented letters, and these are matched by \w.

In UTF-8 mode, characters with values greater than 128 never match \d, \s, or \w, and always match \D, \S, and \W. This is true even when Unicode character property support is available. The use of locales with Unicode is discouraged.

Unicode character properties

When PCRE is built with Unicode character property support, three additional escape sequences to match character properties are available when UTF-8 mode is selected. They are:

  \p{xx}   a character with the xx property
  \P{xx}   a character without the xx property
  \X       an extended Unicode sequence
The property names represented by xx above are limited to the Unicode script names, the general category properties, and "Any", which matches any character (including newline). Other properties such as "InMusicalSymbols" are not currently supported by PCRE. Note that \P{Any} does not match any characters, so always causes a match failure.

Sets of Unicode characters are defined as belonging to certain scripts. A character from one of these sets can be matched using a script name. For example:

  \p{Greek}
  \P{Han}
Those that are not part of an identified script are lumped together as "Common". The current list of scripts is:

Arabic, Armenian, Bengali, Bopomofo, Braille, Buginese, Buhid, Canadian_Aboriginal, Cherokee, Common, Coptic, Cypriot, Cyrillic, Deseret, Devanagari, Ethiopic, Georgian, Glagolitic, Gothic, Greek, Gujarati, Gurmukhi, Han, Hangul, Hanunoo, Hebrew, Hiragana, Inherited, Kannada, Katakana, Kharoshthi, Khmer, Lao, Latin, Limbu, Linear_B, Malayalam, Mongolian, Myanmar, New_Tai_Lue, Ogham, Old_Italic, Old_Persian, Oriya, Osmanya, Runic, Shavian, Sinhala, Syloti_Nagri, Syriac, Tagalog, Tagbanwa, Tai_Le, Tamil, Telugu, Thaana, Thai, Tibetan, Tifinagh, Ugaritic, Yi.

Each character has exactly one general category property, specified by a two-letter abbreviation. For compatibility with Perl, negation can be specified by including a circumflex between the opening brace and the property name. For example, \p{^Lu} is the same as \P{Lu}.

If only one letter is specified with \p or \P, it includes all the general category properties that start with that letter. In this case, in the absence of negation, the curly brackets in the escape sequence are optional; these two examples have the same effect:

  \p{L}
  \pL
The following general category property codes are supported:
  C     Other
  Cc    Control
  Cf    Format
  Cn    Unassigned
  Co    Private use
  Cs    Surrogate

  L     Letter
  Ll    Lower case letter
  Lm    Modifier letter
  Lo    Other letter
  Lt    Title case letter
  Lu    Upper case letter

  M     Mark
  Mc    Spacing mark
  Me    Enclosing mark
  Mn    Non-spacing mark

  N     Number
  Nd    Decimal number
  Nl    Letter number
  No    Other number

  P     Punctuation
  Pc    Connector punctuation
  Pd    Dash punctuation
  Pe    Close punctuation
  Pf    Final punctuation
  Pi    Initial punctuation
  Po    Other punctuation
  Ps    Open punctuation

  S     Symbol
  Sc    Currency symbol
  Sk    Modifier symbol
  Sm    Mathematical symbol
  So    Other symbol

  Z     Separator
  Zl    Line separator
  Zp    Paragraph separator
  Zs    Space separator
The special property L& is also supported: it matches a character that has the Lu, Ll, or Lt property, in other words, a letter that is not classified as a modifier or "other".

The long synonyms for these properties that Perl supports (such as \p{Letter}) are not supported by PCRE, nor is it permitted to prefix any of these properties with "Is".

No character that is in the Unicode table has the Cn (unassigned) property. Instead, this property is assumed for any code point that is not in the Unicode table.

Specifying caseless matching does not affect these escape sequences. For example, \p{Lu} always matches only upper case letters.

The \X escape matches any number of Unicode characters that form an extended Unicode sequence. \X is equivalent to

  (?>\PM\pM*)
That is, it matches a character without the "mark" property, followed by zero or more characters with the "mark" property, and treats the sequence as an atomic group (see below). Characters with the "mark" property are typically accents that affect the preceding character.

Matching characters by Unicode property is not fast, because PCRE has to search a structure that contains data for over fifteen thousand characters. That is why the traditional escape sequences such as \d and \w do not use Unicode properties in PCRE.

Simple assertions

The fourth use of backslash is for certain simple assertions. An assertion specifies a condition that has to be met at a particular point in a match, without consuming any characters from the subject string. The use of subpatterns for more complicated assertions is described below. The backslashed assertions are:

  \b     matches at a word boundary
  \B     matches when not at a word boundary
  \A     matches at start of subject
  \Z     matches at end of subject or before newline at end
  \z     matches at end of subject
  \G     matches at first matching position in subject
These assertions may not appear in character classes (but note that \b has a different meaning, namely the backspace character, inside a character class).

A word boundary is a position in the subject string where the current character and the previous character do not both match \w or \W (i.e. one matches \w and the other matches \W), or the start or end of the string if the first or last character matches \w, respectively.

The \A, \Z, and \z assertions differ from the traditional circumflex and dollar (described in the next section) in that they only ever match at the very start and end of the subject string, whatever options are set. Thus, they are independent of multiline mode. These three assertions are not affected by the PCRE_NOTBOL or PCRE_NOTEOL options, which affect only the behaviour of the circumflex and dollar metacharacters. However, if the startoffset argument of pcre_exec() is non-zero, indicating that matching is to start at a point other than the beginning of the subject, \A can never match. The difference between \Z and \z is that \Z matches before a newline at the end of the string as well as at the very end, whereas \z matches only at the end.

The \G assertion is true only when the current matching position is at the start point of the match, as specified by the startoffset argument of pcre_exec(). It differs from \A when the value of startoffset is non-zero. By calling pcre_exec() multiple times with appropriate arguments, you can mimic Perl's /g option, and it is in this kind of implementation where \G can be useful.

Note, however, that PCRE's interpretation of \G, as the start of the current match, is subtly different from Perl's, which defines it as the end of the previous match. In Perl, these can be different when the previously matched string was empty. Because PCRE does just one match at a time, it cannot reproduce this behaviour.

If all the alternatives of a pattern begin with \G, the expression is anchored to the starting match position, and the "anchored" flag is set in the compiled regular expression.

CIRCUMFLEX AND DOLLAR

Outside a character class, in the default matching mode, the circumflex character is an assertion that is true only if the current matching point is at the start of the subject string. If the startoffset argument of pcre_exec() is non-zero, circumflex can never match if the PCRE_MULTILINE option is unset. Inside a character class, circumflex has an entirely different meaning (see below).

Circumflex need not be the first character of the pattern if a number of alternatives are involved, but it should be the first thing in each alternative in which it appears if the pattern is ever to match that branch. If all possible alternatives start with a circumflex, that is, if the pattern is constrained to match only at the start of the subject, it is said to be an "anchored" pattern. (There are also other constructs that can cause a pattern to be anchored.)

A dollar character is an assertion that is true only if the current matching point is at the end of the subject string, or immediately before a newline at the end of the string (by default). Dollar need not be the last character of the pattern if a number of alternatives are involved, but it should be the last item in any branch in which it appears. Dollar has no special meaning in a character class.

The meaning of dollar can be changed so that it matches only at the very end of the string, by setting the PCRE_DOLLAR_ENDONLY option at compile time. This does not affect the \Z assertion.

The meanings of the circumflex and dollar characters are changed if the PCRE_MULTILINE option is set. When this is the case, a circumflex matches immediately after internal newlines as well as at the start of the subject string. It does not match after a newline that ends the string. A dollar matches before any newlines in the string, as well as at the very end, when PCRE_MULTILINE is set. When newline is specified as the two-character sequence CRLF, isolated CR and LF characters do not indicate newlines.

For example, the pattern /^abc$/ matches the subject string "def\nabc" (where \n represents a newline) in multiline mode, but not otherwise. Consequently, patterns that are anchored in single line mode because all branches start with ^ are not anchored in multiline mode, and a match for circumflex is possible when the startoffset argument of pcre_exec() is non-zero. The PCRE_DOLLAR_ENDONLY option is ignored if PCRE_MULTILINE is set.

Note that the sequences \A, \Z, and \z can be used to match the start and end of the subject in both modes, and if all branches of a pattern start with \A it is always anchored, whether or not PCRE_MULTILINE is set.

FULL STOP (PERIOD, DOT)

Outside a character class, a dot in the pattern matches any one character in the subject string except (by default) a character that signifies the end of a line. In UTF-8 mode, the matched character may be more than one byte long. When a line ending is defined as a single character (CR or LF), dot never matches that character; when the two-character sequence CRLF is used, dot does not match CR if it is immediately followed by LF, but otherwise it matches all characters (including isolated CRs and LFs).

The behaviour of dot with regard to newlines can be changed. If the PCRE_DOTALL option is set, a dot matches any one character, without exception. If newline is defined as the two-character sequence CRLF, it takes two dots to match it.

The handling of dot is entirely independent of the handling of circumflex and dollar, the only relationship being that they both involve newlines. Dot has no special meaning in a character class.

MATCHING A SINGLE BYTE

Outside a character class, the escape sequence \C matches any one byte, both in and out of UTF-8 mode. Unlike a dot, it always matches CR and LF. The feature is provided in Perl in order to match individual bytes in UTF-8 mode. Because it breaks up UTF-8 characters into individual bytes, what remains in the string may be a malformed UTF-8 string. For this reason, the \C escape sequence is best avoided.

PCRE does not allow \C to appear in lookbehind assertions (described below), because in UTF-8 mode this would make it impossible to calculate the length of the lookbehind.

SQUARE BRACKETS AND CHARACTER CLASSES

An opening square bracket introduces a character class, terminated by a closing square bracket. A closing square bracket on its own is not special. If a closing square bracket is required as a member of the class, it should be the first data character in the class (after an initial circumflex, if present) or escaped with a backslash.

A character class matches a single character in the subject. In UTF-8 mode, the character may occupy more than one byte. A matched character must be in the set of characters defined by the class, unless the first character in the class definition is a circumflex, in which case the subject character must not be in the set defined by the class. If a circumflex is actually required as a member of the class, ensure it is not the first character, or escape it with a backslash.

For example, the character class [aeiou] matches any lower case vowel, while [^aeiou] matches any character that is not a lower case vowel. Note that a circumflex is just a convenient notation for specifying the characters that are in the class by enumerating those that are not. A class that starts with a circumflex is not an assertion: it still consumes a character from the subject string, and therefore it fails if the current pointer is at the end of the string.

In UTF-8 mode, characters with values greater than 255 can be included in a class as a literal string of bytes, or by using the \x{ escaping mechanism.

When caseless matching is set, any letters in a class represent both their upper case and lower case versions, so for example, a caseless [aeiou] matches "A" as well as "a", and a caseless [^aeiou] does not match "A", whereas a caseful version would. In UTF-8 mode, PCRE always understands the concept of case for characters whose values are less than 128, so caseless matching is always possible. For characters with higher values, the concept of case is supported if PCRE is compiled with Unicode property support, but not otherwise. If you want to use caseless matching for characters 128 and above, you must ensure that PCRE is compiled with Unicode property support as well as with UTF-8 support.

Characters that might indicate line breaks (CR and LF) are never treated in any special way when matching character classes, whatever line-ending sequence is in use, and whatever setting of the PCRE_DOTALL and PCRE_MULTILINE options is used. A class such as [^a] always matches one of these characters.

The minus (hyphen) character can be used to specify a range of characters in a character class. For example, [d-m] matches any letter between d and m, inclusive. If a minus character is required in a class, it must be escaped with a backslash or appear in a position where it cannot be interpreted as indicating a range, typically as the first or last character in the class.

It is not possible to have the literal character "]" as the end character of a range. A pattern such as [W-]46] is interpreted as a class of two characters ("W" and "-") followed by a literal string "46]", so it would match "W46]" or "-46]". However, if the "]" is escaped with a backslash it is interpreted as the end of range, so [W-\]46] is interpreted as a class containing a range followed by two other characters. The octal or hexadecimal representation of "]" can also be used to end a range.

Ranges operate in the collating sequence of character values. They can also be used for characters specified numerically, for example [\000-\037]. In UTF-8 mode, ranges can include characters whose values are greater than 255, for example [\x{100}-\x{2ff}].

If a range that includes letters is used when caseless matching is set, it matches the letters in either case. For example, [W-c] is equivalent to [][\\^_`wxyzabc], matched caselessly, and in non-UTF-8 mode, if character tables for the "fr_FR" locale are in use, [\xc8-\xcb] matches accented E characters in both cases. In UTF-8 mode, PCRE supports the concept of case for characters with values greater than 128 only when it is compiled with Unicode property support.

The character types \d, \D, \p, \P, \s, \S, \w, and \W may also appear in a character class, and add the characters that they match to the class. For example, [\dABCDEF] matches any hexadecimal digit. A circumflex can conveniently be used with the upper case character types to specify a more restricted set of characters than the matching lower case type. For example, the class [^\W_] matches any letter or digit, but not underscore.

The only metacharacters that are recognized in character classes are backslash, hyphen (only where it can be interpreted as specifying a range), circumflex (only at the start), opening square bracket (only when it can be interpreted as introducing a POSIX class name - see the next section), and the terminating closing square bracket. However, escaping other non-alphanumeric characters does no harm.

POSIX CHARACTER CLASSES

Perl supports the POSIX notation for character classes. This uses names enclosed by [: and :] within the enclosing square brackets. PCRE also supports this notation. For example,

  [01[:alpha:]%]
matches "0", "1", any alphabetic character, or "%". The supported class names are
  alnum    letters and digits
  alpha    letters
  ascii    character codes 0 - 127
  blank    space or tab only
  cntrl    control characters
  digit    decimal digits (same as \d)
  graph    printing characters, excluding space
  lower    lower case letters
  print    printing characters, including space
  punct    printing characters, excluding letters and digits
  space    white space (not quite the same as \s)
  upper    upper case letters
  word     "word" characters (same as \w)
  xdigit   hexadecimal digits
The "space" characters are HT (9), LF (10), VT (11), FF (12), CR (13), and space (32). Notice that this list includes the VT character (code 11). This makes "space" different to \s, which does not include VT (for Perl compatibility).

The name "word" is a Perl extension, and "blank" is a GNU extension from Perl 5.8. Another Perl extension is negation, which is indicated by a ^ character after the colon. For example,

  [12[:^digit:]]
matches "1", "2", or any non-digit. PCRE (and Perl) also recognize the POSIX syntax [.ch.] and [=ch=] where "ch" is a "collating element", but these are not supported, and an error is given if they are encountered.

In UTF-8 mode, characters with values greater than 128 do not match any of the POSIX character classes.

VERTICAL BAR

Vertical bar characters are used to separate alternative patterns. For example, the pattern

  gilbert|sullivan
matches either "gilbert" or "sullivan". Any number of alternatives may appear, and an empty alternative is permitted (matching the empty string). The matching process tries each alternative in turn, from left to right, and the first one that succeeds is used. If the alternatives are within a subpattern (defined below), "succeeds" means matching the rest of the main pattern as well as the alternative in the subpattern.

INTERNAL OPTION SETTING

The settings of the PCRE_CASELESS, PCRE_MULTILINE, PCRE_DOTALL, and PCRE_EXTENDED options can be changed from within the pattern by a sequence of Perl option letters enclosed between "(?" and ")". The option letters are

  i  for PCRE_CASELESS
  m  for PCRE_MULTILINE
  s  for PCRE_DOTALL
  x  for PCRE_EXTENDED
For example, (?im) sets caseless, multiline matching. It is also possible to unset these options by preceding the letter with a hyphen, and a combined setting and unsetting such as (?im-sx), which sets PCRE_CASELESS and PCRE_MULTILINE while unsetting PCRE_DOTALL and PCRE_EXTENDED, is also permitted. If a letter appears both before and after the hyphen, the option is unset.

When an option change occurs at top level (that is, not inside subpattern parentheses), the change applies to the remainder of the pattern that follows. If the change is placed right at the start of a pattern, PCRE extracts it into the global options (and it will therefore show up in data extracted by the pcre_fullinfo() function).

An option change within a subpattern affects only that part of the current pattern that follows it, so

  (a(?i)b)c
matches abc and aBc and no other strings (assuming PCRE_CASELESS is not used). By this means, options can be made to have different settings in different parts of the pattern. Any changes made in one alternative do carry on into subsequent branches within the same subpattern. For example,
  (a(?i)b|c)
matches "ab", "aB", "c", and "C", even though when matching "C" the first branch is abandoned before the option setting. This is because the effects of option settings happen at compile time. There would be some very weird behaviour otherwise.

The PCRE-specific options PCRE_DUPNAMES, PCRE_UNGREEDY, and PCRE_EXTRA can be changed in the same way as the Perl-compatible options by using the characters J, U and X respectively.

SUBPATTERNS

Subpatterns are delimited by parentheses (round brackets), which can be nested. Turning part of a pattern into a subpattern does two things:

1. It localizes a set of alternatives. For example, the pattern

  cat(aract|erpillar|)
matches one of the words "cat", "cataract", or "caterpillar". Without the parentheses, it would match "cataract", "erpillar" or the empty string.

2. It sets up the subpattern as a capturing subpattern. This means that, when the whole pattern matches, that portion of the subject string that matched the subpattern is passed back to the caller via the ovector argument of pcre_exec(). Opening parentheses are counted from left to right (starting from 1) to obtain numbers for the capturing subpatterns.

For example, if the string "the red king" is matched against the pattern

  the ((red|white) (king|queen))
the captured substrings are "red king", "red", and "king", and are numbered 1, 2, and 3, respectively.

The fact that plain parentheses fulfil two functions is not always helpful. There are often times when a grouping subpattern is required without a capturing requirement. If an opening parenthesis is followed by a question mark and a colon, the subpattern does not do any capturing, and is not counted when computing the number of any subsequent capturing subpatterns. For example, if the string "the white queen" is matched against the pattern

  the ((?:red|white) (king|queen))
the captured substrings are "white queen" and "queen", and are numbered 1 and 2. The maximum number of capturing subpatterns is 65535, and the maximum depth of nesting of all subpatterns, both capturing and non-capturing, is 200.

As a convenient shorthand, if any option settings are required at the start of a non-capturing subpattern, the option letters may appear between the "?" and the ":". Thus the two patterns

  (?i:saturday|sunday)
  (?:(?i)saturday|sunday)
match exactly the same set of strings. Because alternative branches are tried from left to right, and options are not reset until the end of the subpattern is reached, an option setting in one branch does affect subsequent branches, so the above patterns match "SUNDAY" as well as "Saturday".

NAMED SUBPATTERNS

Identifying capturing parentheses by number is simple, but it can be very hard to keep track of the numbers in complicated regular expressions. Furthermore, if an expression is modified, the numbers may change. To help with this difficulty, PCRE supports the naming of subpatterns, something that Perl does not provide. The Python syntax (?P<name>...) is used. References to capturing parentheses from other parts of the pattern, such as backreferences, recursion, and conditions, can be made by name as well as by number.

Names consist of up to 32 alphanumeric characters and underscores. Named capturing parentheses are still allocated numbers as well as names. The PCRE API provides function calls for extracting the name-to-number translation table from a compiled pattern. There is also a convenience function for extracting a captured substring by name.

By default, a name must be unique within a pattern, but it is possible to relax this constraint by setting the PCRE_DUPNAMES option at compile time. This can be useful for patterns where only one instance of the named parentheses can match. Suppose you want to match the name of a weekday, either as a 3-letter abbreviation or as the full name, and in both cases you want to extract the abbreviation. This pattern (ignoring the line breaks) does the job:

  (?P<DN>Mon|Fri|Sun)(?:day)?|
  (?P<DN>Tue)(?:sday)?|
  (?P<DN>Wed)(?:nesday)?|
  (?P<DN>Thu)(?:rsday)?|
  (?P<DN>Sat)(?:urday)?
There are five capturing substrings, but only one is ever set after a match. The convenience function for extracting the data by name returns the substring for the first, and in this example, the only, subpattern of that name that matched. This saves searching to find which numbered subpattern it was. If you make a reference to a non-unique named subpattern from elsewhere in the pattern, the one that corresponds to the lowest number is used. For further details of the interfaces for handling named subpatterns, see the pcreapi documentation.

REPETITION

Repetition is specified by quantifiers, which can follow any of the following items:

  a literal data character
  the . metacharacter
  the \C escape sequence
  the \X escape sequence (in UTF-8 mode with Unicode properties)
  an escape such as \d that matches a single character
  a character class
  a back reference (see next section)
  a parenthesized subpattern (unless it is an assertion)
The general repetition quantifier specifies a minimum and maximum number of permitted matches, by giving the two numbers in curly brackets (braces), separated by a comma. The numbers must be less than 65536, and the first must be less than or equal to the second. For example:
  z{2,4}
matches "zz", "zzz", or "zzzz". A closing brace on its own is not a special character. If the second number is omitted, but the comma is present, there is no upper limit; if the second number and the comma are both omitted, the quantifier specifies an exact number of required matches. Thus
  [aeiou]{3,}
matches at least 3 successive vowels, but may match many more, while
  \d{8}
matches exactly 8 digits. An opening curly bracket that appears in a position where a quantifier is not allowed, or one that does not match the syntax of a quantifier, is taken as a literal character. For example, {,6} is not a quantifier, but a literal string of four characters.

In UTF-8 mode, quantifiers apply to UTF-8 characters rather than to individual bytes. Thus, for example, \x{100}{2} matches two UTF-8 characters, each of which is represented by a two-byte sequence. Similarly, when Unicode property support is available, \X{3} matches three Unicode extended sequences, each of which may be several bytes long (and they may be of different lengths).

The quantifier {0} is permitted, causing the expression to behave as if the previous item and the quantifier were not present.

For convenience (and historical compatibility) the three most common quantifiers have single-character abbreviations:

  *    is equivalent to {0,}
  +    is equivalent to {1,}
  ?    is equivalent to {0,1}
It is possible to construct infinite loops by following a subpattern that can match no characters with a quantifier that has no upper limit, for example:
  (a?)*
Earlier versions of Perl and PCRE used to give an error at compile time for such patterns. However, because there are cases where this can be useful, such patterns are now accepted, but if any repetition of the subpattern does in fact match no characters, the loop is forcibly broken.

By default, the quantifiers are "greedy", that is, they match as much as possible (up to the maximum number of permitted times), without causing the rest of the pattern to fail. The classic example of where this gives problems is in trying to match comments in C programs. These appear between /* and */ and within the comment, individual * and / characters may appear. An attempt to match C comments by applying the pattern

  /\*.*\*/
to the string
  /* first comment */  not comment  /* second comment */
fails, because it matches the entire string owing to the greediness of the .* item.

However, if a quantifier is followed by a question mark, it ceases to be greedy, and instead matches the minimum number of times possible, so the pattern

  /\*.*?\*/
does the right thing with the C comments. The meaning of the various quantifiers is not otherwise changed, just the preferred number of matches. Do not confuse this use of question mark with its use as a quantifier in its own right. Because it has two uses, it can sometimes appear doubled, as in
  \d??\d
which matches one digit by preference, but can match two if that is the only way the rest of the pattern matches.

If the PCRE_UNGREEDY option is set (an option which is not available in Perl), the quantifiers are not greedy by default, but individual ones can be made greedy by following them with a question mark. In other words, it inverts the default behaviour.

When a parenthesized subpattern is quantified with a minimum repeat count that is greater than 1 or with a limited maximum, more memory is required for the compiled pattern, in proportion to the size of the minimum or maximum.

If a pattern starts with .* or .{0,} and the PCRE_DOTALL option (equivalent to Perl's /s) is set, thus allowing the . to match newlines, the pattern is implicitly anchored, because whatever follows will be tried against every character position in the subject string, so there is no point in retrying the overall match at any position after the first. PCRE normally treats such a pattern as though it were preceded by \A.

In cases where it is known that the subject string contains no newlines, it is worth setting PCRE_DOTALL in order to obtain this optimization, or alternatively using ^ to indicate anchoring explicitly.

However, there is one situation where the optimization cannot be used. When .* is inside capturing parentheses that are the subject of a backreference elsewhere in the pattern, a match at the start may fail, and a later one succeed. Consider, for example:

  (.*)abc\1
If the subject is "xyz123abc123" the match point is the fourth character. For this reason, such a pattern is not implicitly anchored.

When a capturing subpattern is repeated, the value captured is the substring that matched the final iteration. For example, after

  (tweedle[dume]{3}\s*)+
has matched "tweedledum tweedledee" the value of the captured substring is "tweedledee". However, if there are nested capturing subpatterns, the corresponding captured values may have been set in previous iterations. For example, after
  /(a|(b))+/
matches "aba" the value of the second captured substring is "b".

ATOMIC GROUPING AND POSSESSIVE QUANTIFIERS

With both maximizing and minimizing repetition, failure of what follows normally causes the repeated item to be re-evaluated to see if a different number of repeats allows the rest of the pattern to match. Sometimes it is useful to prevent this, either to change the nature of the match, or to cause it fail earlier than it otherwise might, when the author of the pattern knows there is no point in carrying on.

Consider, for example, the pattern \d+foo when applied to the subject line

  123456bar
After matching all 6 digits and then failing to match "foo", the normal action of the matcher is to try again with only 5 digits matching the \d+ item, and then with 4, and so on, before ultimately failing. "Atomic grouping" (a term taken from Jeffrey Friedl's book) provides the means for specifying that once a subpattern has matched, it is not to be re-evaluated in this way.

If we use atomic grouping for the previous example, the matcher would give up immediately on failing to match "foo" the first time. The notation is a kind of special parenthesis, starting with (?> as in this example:

  (?>\d+)foo
This kind of parenthesis "locks up" the part of the pattern it contains once it has matched, and a failure further into the pattern is prevented from backtracking into it. Backtracking past it to previous items, however, works as normal.

An alternative description is that a subpattern of this type matches the string of characters that an identical standalone pattern would match, if anchored at the current point in the subject string.

Atomic grouping subpatterns are not capturing subpatterns. Simple cases such as the above example can be thought of as a maximizing repeat that must swallow everything it can. So, while both \d+ and \d+? are prepared to adjust the number of digits they match in order to make the rest of the pattern match, (?>\d+) can only match an entire sequence of digits.

Atomic groups in general can of course contain arbitrarily complicated subpatterns, and can be nested. However, when the subpattern for an atomic group is just a single repeated item, as in the example above, a simpler notation, called a "possessive quantifier" can be used. This consists of an additional + character following a quantifier. Using this notation, the previous example can be rewritten as

  \d++foo
Possessive quantifiers are always greedy; the setting of the PCRE_UNGREEDY option is ignored. They are a convenient notation for the simpler forms of atomic group. However, there is no difference in the meaning or processing of a possessive quantifier and the equivalent atomic group.

The possessive quantifier syntax is an extension to the Perl syntax. Jeffrey Friedl originated the idea (and the name) in the first edition of his book. Mike McCloskey liked it, so implemented it when he built Sun's Java package, and PCRE copied it from there.

When a pattern contains an unlimited repeat inside a subpattern that can itself be repeated an unlimited number of times, the use of an atomic group is the only way to avoid some failing matches taking a very long time indeed. The pattern

  (\D+|<\d+>)*[!?]
matches an unlimited number of substrings that either consist of non-digits, or digits enclosed in <>, followed by either ! or ?. When it matches, it runs quickly. However, if it is applied to
  aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
it takes a long time before reporting failure. This is because the string can be divided between the internal \D+ repeat and the external * repeat in a large number of ways, and all have to be tried. (The example uses [!?] rather than a single character at the end, because both PCRE and Perl have an optimization that allows for fast failure when a single character is used. They remember the last single character that is required for a match, and fail early if it is not present in the string.) If the pattern is changed so that it uses an atomic group, like this:
  ((?>\D+)|<\d+>)*[!?]
sequences of non-digits cannot be broken, and failure happens quickly.

BACK REFERENCES

Outside a character class, a backslash followed by a digit greater than 0 (and possibly further digits) is a back reference to a capturing subpattern earlier (that is, to its left) in the pattern, provided there have been that many previous capturing left parentheses.

However, if the decimal number following the backslash is less than 10, it is always taken as a back reference, and causes an error only if there are not that many capturing left parentheses in the entire pattern. In other words, the parentheses that are referenced need not be to the left of the reference for numbers less than 10. A "forward back reference" of this type can make sense when a repetition is involved and the subpattern to the right has participated in an earlier iteration.

It is not possible to have a numerical "forward back reference" to subpattern whose number is 10 or more. However, a back reference to any subpattern is possible using named parentheses (see below). See also the subsection entitled "Non-printing characters" above for further details of the handling of digits following a backslash.

A back reference matches whatever actually matched the capturing subpattern in the current subject string, rather than anything matching the subpattern itself (see "Subpatterns as subroutines" below for a way of doing that). So the pattern

  (sens|respons)e and \1ibility
matches "sense and sensibility" and "response and responsibility", but not "sense and responsibility". If caseful matching is in force at the time of the back reference, the case of letters is relevant. For example,
  ((?i)rah)\s+\1
matches "rah rah" and "RAH RAH", but not "RAH rah", even though the original capturing subpattern is matched caselessly.

Back references to named subpatterns use the Python syntax (?P=name). We could rewrite the above example as follows:

  (?P<p1>(?i)rah)\s+(?P=p1)
A subpattern that is referenced by name may appear in the pattern before or after the reference.

There may be more than one back reference to the same subpattern. If a subpattern has not actually been used in a particular match, any back references to it always fail. For example, the pattern

  (a|(bc))\2
always fails if it starts to match "a" rather than "bc". Because there may be many capturing parentheses in a pattern, all digits following the backslash are taken as part of a potential back reference number. If the pattern continues with a digit character, some delimiter must be used to terminate the back reference. If the PCRE_EXTENDED option is set, this can be whitespace. Otherwise an empty comment (see "Comments" below) can be used.

A back reference that occurs inside the parentheses to which it refers fails when the subpattern is first used, so, for example, (a\1) never matches. However, such references can be useful inside repeated subpatterns. For example, the pattern

  (a|b\1)+
matches any number of "a"s and also "aba", "ababbaa" etc. At each iteration of the subpattern, the back reference matches the character string corresponding to the previous iteration. In order for this to work, the pattern must be such that the first iteration does not need to match the back reference. This can be done using alternation, as in the example above, or by a quantifier with a minimum of zero.

ASSERTIONS

An assertion is a test on the characters following or preceding the current matching point that does not actually consume any characters. The simple assertions coded as \b, \B, \A, \G, \Z, \z, ^ and $ are described above.

More complicated assertions are coded as subpatterns. There are two kinds: those that look ahead of the current position in the subject string, and those that look behind it. An assertion subpattern is matched in the normal way, except that it does not cause the current matching position to be changed.

Assertion subpatterns are not capturing subpatterns, and may not be repeated, because it makes no sense to assert the same thing several times. If any kind of assertion contains capturing subpatterns within it, these are counted for the purposes of numbering the capturing subpatterns in the whole pattern. However, substring capturing is carried out only for positive assertions, because it does not make sense for negative assertions.

Lookahead assertions

Lookahead assertions start with (?= for positive assertions and (?! for negative assertions. For example,

  \w+(?=;)
matches a word followed by a semicolon, but does not include the semicolon in the match, and
  foo(?!bar)
matches any occurrence of "foo" that is not followed by "bar". Note that the apparently similar pattern
  (?!foo)bar
does not find an occurrence of "bar" that is preceded by something other than "foo"; it finds any occurrence of "bar" whatsoever, because the assertion (?!foo) is always true when the next three characters are "bar". A lookbehind assertion is needed to achieve the other effect.

If you want to force a matching failure at some point in a pattern, the most convenient way to do it is with (?!) because an empty string always matches, so an assertion that requires there not to be an empty string must always fail.

Lookbehind assertions

Lookbehind assertions start with (?<= for positive assertions and (?<! for negative assertions. For example,

  (?<!foo)bar
does find an occurrence of "bar" that is not preceded by "foo". The contents of a lookbehind assertion are restricted such that all the strings it matches must have a fixed length. However, if there are several top-level alternatives, they do not all have to have the same fixed length. Thus
  (?<=bullock|donkey)
is permitted, but
  (?<!dogs?|cats?)
causes an error at compile time. Branches that match different length strings are permitted only at the top level of a lookbehind assertion. This is an extension compared with Perl (at least for 5.8), which requires all branches to match the same length of string. An assertion such as
  (?<=ab(c|de))
is not permitted, because its single top-level branch can match two different lengths, but it is acceptable if rewritten to use two top-level branches:
  (?<=abc|abde)
The implementation of lookbehind assertions is, for each alternative, to temporarily move the current position back by the fixed width and then try to match. If there are insufficient characters before the current position, the match is deemed to fail.

PCRE does not allow the \C escape (which matches a single byte in UTF-8 mode) to appear in lookbehind assertions, because it makes it impossible to calculate the length of the lookbehind. The \X escape, which can match different numbers of bytes, is also not permitted.

Atomic groups can be used in conjunction with lookbehind assertions to specify efficient matching at the end of the subject string. Consider a simple pattern such as

  abcd$
when applied to a long string that does not match. Because matching proceeds from left to right, PCRE will look for each "a" in the subject and then see if what follows matches the rest of the pattern. If the pattern is specified as
  ^.*abcd$
the initial .* matches the entire string at first, but when this fails (because there is no following "a"), it backtracks to match all but the last character, then all but the last two characters, and so on. Once again the search for "a" covers the entire string, from right to left, so we are no better off. However, if the pattern is written as
  ^(?>.*)(?<=abcd)
or, equivalently, using the possessive quantifier syntax,
  ^.*+(?<=abcd)
there can be no backtracking for the .* item; it can match only the entire string. The subsequent lookbehind assertion does a single test on the last four characters. If it fails, the match fails immediately. For long strings, this approach makes a significant difference to the processing time.

Using multiple assertions

Several assertions (of any sort) may occur in succession. For example,

  (?<=\d{3})(?<!999)foo
matches "foo" preceded by three digits that are not "999". Notice that each of the assertions is applied independently at the same point in the subject string. First there is a check that the previous three characters are all digits, and then there is a check that the same three characters are not "999". This pattern does not match "foo" preceded by six characters, the first of which are digits and the last three of which are not "999". For example, it doesn't match "123abcfoo". A pattern to do that is
  (?<=\d{3}...)(?<!999)foo
This time the first assertion looks at the preceding six characters, checking that the first three are digits, and then the second assertion checks that the preceding three characters are not "999".

Assertions can be nested in any combination. For example,

  (?<=(?<!foo)bar)baz
matches an occurrence of "baz" that is preceded by "bar" which in turn is not preceded by "foo", while
  (?<=\d{3}(?!999)...)foo
is another pattern that matches "foo" preceded by three digits and any three characters that are not "999".

CONDITIONAL SUBPATTERNS

It is possible to cause the matching process to obey a subpattern conditionally or to choose between two alternative subpatterns, depending on the result of an assertion, or whether a previous capturing subpattern matched or not. The two possible forms of conditional subpattern are

  (?(condition)yes-pattern)
  (?(condition)yes-pattern|no-pattern)
If the condition is satisfied, the yes-pattern is used; otherwise the no-pattern (if present) is used. If there are more than two alternatives in the subpattern, a compile-time error occurs.

There are three kinds of condition. If the text between the parentheses consists of a sequence of digits, or a sequence of alphanumeric characters and underscores, the condition is satisfied if the capturing subpattern of that number or name has previously matched. There is a possible ambiguity here, because subpattern names may consist entirely of digits. PCRE looks first for a named subpattern; if it cannot find one and the text consists entirely of digits, it looks for a subpattern of that number, which must be greater than zero. Using subpattern names that consist entirely of digits is not recommended.

Consider the following pattern, which contains non-significant white space to make it more readable (assume the PCRE_EXTENDED option) and to divide it into three parts for ease of discussion:

  ( \( )?    [^()]+    (?(1) \) )
The first part matches an optional opening parenthesis, and if that character is present, sets it as the first captured substring. The second part matches one or more characters that are not parentheses. The third part is a conditional subpattern that tests whether the first set of parentheses matched or not. If they did, that is, if subject started with an opening parenthesis, the condition is true, and so the yes-pattern is executed and a closing parenthesis is required. Otherwise, since no-pattern is not present, the subpattern matches nothing. In other words, this pattern matches a sequence of non-parentheses, optionally enclosed in parentheses. Rewriting it to use a named subpattern gives this:
  (?P<OPEN> \( )?    [^()]+    (?(OPEN) \) )
If the condition is the string (R), and there is no subpattern with the name R, the condition is satisfied if a recursive call to the pattern or subpattern has been made. At "top level", the condition is false. This is a PCRE extension. Recursive patterns are described in the next section.

If the condition is not a sequence of digits or (R), it must be an assertion. This may be a positive or negative lookahead or lookbehind assertion. Consider this pattern, again containing non-significant white space, and with the two alternatives on the second line:

  (?(?=[^a-z]*[a-z])
  \d{2}-[a-z]{3}-\d{2}  |  \d{2}-\d{2}-\d{2} )
The condition is a positive lookahead assertion that matches an optional sequence of non-letters followed by a letter. In other words, it tests for the presence of at least one letter in the subject. If a letter is found, the subject is matched against the first alternative; otherwise it is matched against the second. This pattern matches strings in one of the two forms dd-aaa-dd or dd-dd-dd, where aaa are letters and dd are digits.

COMMENTS

The sequence (?# marks the start of a comment that continues up to the next closing parenthesis. Nested parentheses are not permitted. The characters that make up a comment play no part in the pattern matching at all.

If the PCRE_EXTENDED option is set, an unescaped # character outside a character class introduces a comment that continues to immediately after the next newline in the pattern.

RECURSIVE PATTERNS

Consider the problem of matching a string in parentheses, allowing for unlimited nested parentheses. Without the use of recursion, the best that can be done is to use a pattern that matches up to some fixed depth of nesting. It is not possible to handle an arbitrary nesting depth. Perl provides a facility that allows regular expressions to recurse (amongst other things). It does this by interpolating Perl code in the expression at run time, and the code can refer to the expression itself. A Perl pattern to solve the parentheses problem can be created like this:

  $re = qr{\( (?: (?>[^()]+) | (?p{$re}) )* \)}x;
The (?p{...}) item interpolates Perl code at run time, and in this case refers recursively to the pattern in which it appears. Obviously, PCRE cannot support the interpolation of Perl code. Instead, it supports some special syntax for recursion of the entire pattern, and also for individual subpattern recursion.

The special item that consists of (? followed by a number greater than zero and a closing parenthesis is a recursive call of the subpattern of the given number, provided that it occurs inside that subpattern. (If not, it is a "subroutine" call, which is described in the next section.) The special item (?R) is a recursive call of the entire regular expression.

A recursive subpattern call is always treated as an atomic group. That is, once it has matched some of the subject string, it is never re-entered, even if it contains untried alternatives and there is a subsequent matching failure.

This PCRE pattern solves the nested parentheses problem (assume the PCRE_EXTENDED option is set so that white space is ignored):

  \( ( (?>[^()]+) | (?R) )* \)
First it matches an opening parenthesis. Then it matches any number of substrings which can either be a sequence of non-parentheses, or a recursive match of the pattern itself (that is, a correctly parenthesized substring). Finally there is a closing parenthesis.

If this were part of a larger pattern, you would not want to recurse the entire pattern, so instead you could use this:

  ( \( ( (?>[^()]+) | (?1) )* \) )
We have put the pattern into parentheses, and caused the recursion to refer to them instead of the whole pattern. In a larger pattern, keeping track of parenthesis numbers can be tricky. It may be more convenient to use named parentheses instead. For this, PCRE uses (?P>name), which is an extension to the Python syntax that PCRE uses for named parentheses (Perl does not provide named parentheses). We could rewrite the above example as follows:
  (?P<pn> \( ( (?>[^()]+) | (?P>pn) )* \) )
This particular example pattern contains nested unlimited repeats, and so the use of atomic grouping for matching strings of non-parentheses is important when applying the pattern to strings that do not match. For example, when this pattern is applied to
  (aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa()
it yields "no match" quickly. However, if atomic grouping is not used, the match runs for a very long time indeed because there are so many different ways the + and * repeats can carve up the subject, and all have to be tested before failure can be reported.

At the end of a match, the values set for any capturing subpatterns are those from the outermost level of the recursion at which the subpattern value is set. If you want to obtain intermediate values, a callout function can be used (see the next section and the pcrecallout documentation). If the pattern above is matched against

  (ab(cd)ef)
the value for the capturing parentheses is "ef", which is the last value taken on at the top level. If additional parentheses are added, giving
  \( ( ( (?>[^()]+) | (?R) )* ) \)
     ^                        ^
     ^                        ^
the string they capture is "ab(cd)ef", the contents of the top level parentheses. If there are more than 15 capturing parentheses in a pattern, PCRE has to obtain extra memory to store data during a recursion, which it does by using pcre_malloc, freeing it via pcre_free afterwards. If no memory can be obtained, the match fails with the PCRE_ERROR_NOMEMORY error.

Do not confuse the (?R) item with the condition (R), which tests for recursion. Consider this pattern, which matches text in angle brackets, allowing for arbitrary nesting. Only digits are allowed in nested brackets (that is, when recursing), whereas any characters are permitted at the outer level.

  < (?: (?(R) \d++  | [^<>]*+) | (?R)) * >
In this pattern, (?(R) is the start of a conditional subpattern, with two different alternatives for the recursive and non-recursive cases. The (?R) item is the actual recursive call.

SUBPATTERNS AS SUBROUTINES

If the syntax for a recursive subpattern reference (either by number or by name) is used outside the parentheses to which it refers, it operates like a subroutine in a programming language. An earlier example pointed out that the pattern

  (sens|respons)e and \1ibility
matches "sense and sensibility" and "response and responsibility", but not "sense and responsibility". If instead the pattern
  (sens|respons)e and (?1)ibility
is used, it does match "sense and responsibility" as well as the other two strings. Such references, if given numerically, must follow the subpattern to which they refer. However, named references can refer to later subpatterns.

Like recursive subpatterns, a "subroutine" call is always treated as an atomic group. That is, once it has matched some of the subject string, it is never re-entered, even if it contains untried alternatives and there is a subsequent matching failure.

CALLOUTS

Perl has a feature whereby using the sequence (?{...}) causes arbitrary Perl code to be obeyed in the middle of matching a regular expression. This makes it possible, amongst other things, to extract different substrings that match the same pair of parentheses when there is a repetition.

PCRE provides a similar feature, but of course it cannot obey arbitrary Perl code. The feature is called "callout". The caller of PCRE provides an external function by putting its entry point in the global variable pcre_callout. By default, this variable contains NULL, which disables all calling out.

Within a regular expression, (?C) indicates the points at which the external function is to be called. If you want to identify different callout points, you can put a number less than 256 after the letter C. The default value is zero. For example, this pattern has two callout points:

  (?C1)\dabc(?C2)def
If the PCRE_AUTO_CALLOUT flag is passed to pcre_compile(), callouts are automatically installed before each item in the pattern. They are all numbered 255.

During matching, when PCRE reaches a callout point (and pcre_callout is set), the external function is called. It is provided with the number of the callout, the position in the pattern, and, optionally, one item of data originally supplied by the caller of pcre_exec(). The callout function may cause matching to proceed, to backtrack, or to fail altogether. A complete description of the interface to the callout function is given in the pcrecallout documentation.

Last updated: 06 June 2006
Copyright © 1997-2006 University of Cambridge.


Custom icons

アイコンのカスタマイズ

カスタムアイコンの使用

UV で、カスタムアイコン(in .bmp 形式のみ),を使用したい場合は、 UVのインストールフォルダ内の " Icons " フォルダに使用したい画像をコピーしてください。 その後は、設定ダイアログの "アイコン" ドロップダウンリストから利用可能になります。

オリジナルの UVアイコンを作成する方法:

  • 設定の " アイコン " ドロップダウンリストからアイテムを選択して "テンプレートとして保存" を選択してください。選択したディレクトリに .bmp ファイルが作成されます。
  • 作成したファイルをグラフィックエディタで開いて、 ビットマップのサイズを、アスペクト比を変更しないで 必要な大きさにリサイズしてください。デフォルトのアイコンサイズは、16x16 です。 例えば 24x24 - だった場合は 150% のリサイズを実行してください。
  • 必要であればアイコンを編集してください。 例えば、ツールバーに表示されるアイコンのみを変更したい時は、 そのアイコンのみを編集するようにしてください。
    特定のコマンドに対応するアイコンを確認したい場合は "設定" ダイアログの、"ショートカット" ページを参照してください。
    注意: 透明色はビットマップの左下部分の色です。
  • 作成したファイルの名前を付けます。どこのアイコンか分かるように、"名前 NNxNN.bmp"、の様に名前を付けてください。 "NN" は、ビットマップの高さを指定します。

是非あなたの作成したファイルをサイトに送ってください! ( " legal " なアイコンに限ります )


カスタム配布版の作成

あなたが、自分の好みに設定を保存した状態で、Universal Viewer を自由に 再配布することが出来ます。
また、リスタープラグインの作者に許可を得ている場合は、あなたの パッケージの中に、プラグインをプレインストールする
ことも可能です。 その際は、デフォルトヘルプ とデフォルト言語ファイルを同梱することが推奨されますが、これは必ず必要
というわけではありません。

プラグイン込みの UV パッケージを作成する際のヒント
プログラムは、最初に環境変数 %ATViewer% を設定して、UV が実行されたフォルダを 参照します。そして、 この変数を使用して、Viewer.ini ファイルの相対パスを保存します。 その後、必要なプラグインをインストールします。
UV フォルダにある "Plugins" フォルダ、またその中のサブフォルダのパスは 自動的に Viewer.ini ファイルに保存されます:

[ListerPlugins]
0=%ATViewer%\Plugins\OOoViewer\OOoViewer.wlx
すべてのプラグインがこのようにプレインストールされるなら、UVフォルダ全体をパックして、 別の PC でアンパック後、プラグインを使用してみて問題がないか確認するべきです。


更新履歴

プロ版に関する注意: 2009 3月1日以降に入手された登録キーは、ver.4 に更新する 必要があります。あなたの旧reg データをサポートメールまで送信してください。 その他のすべての 3.x バージョンの登録キーが無効になる訳ではありません。

Version 5.0.0 (8 oct 2009)

  • 追加: MS Office ネイティブ表示 (番号 '9'). Word/Excel 新規ウィンドウを開きません
  • 追加: テキスト変換 (上部緑色のバー) DOC/DOCX/XLS/XLSX/PPT/WRI/PDF/123 その他の文書を相互変換します。
  • 追加: ソースコードの構文強調表示: PAS/C/CPP/ASM/BAT/REG/INI その他. Syn プラグインを使用します。
  • 追加: Exe/DLL アイコン表示, ICLView プラグインを使用します。
  • 追加: MS Office, OpenOffice 形式の設定
  • 変更: ini キー (殆どの隠しオプション)の名前を変更しました。 設定を再確認してください。
  • 変更: NavPanel 上に移動ボタン
  • 修正: NavPanel ODT によるハングアップ
  • 追加: プラグイン構文文字列検出、"例:ext1,ext2,...".

Version 4.3.0 (3 sep 2009)

  • 追加: NavPanel:ビューワへのドッキング方法を両方のウィンドウと同期するように最適化
  • 追加: NavPanel: combobox のパス
  • 追加: NavPanel: オプション "combobox を表示", "水平レイアウト".
  • 追加: NavPanel: ドラッグドロップでファイル名を編集
  • 追加: オプション "形式の不明なファイルを開く前に確認"
  • 変更: ユーザツールの使用に NavPanel が必要になりました。

Version 4.2.2 (23 aug 2009)

  • 変更: UV プロ版の仕様変更 ナビゲーションパネルアドオンを分離してシェアウェアに(Nav.exe)変更
  • 機能 (フォルダにコピー, リネーム, リンク対象の解決) をフリーに変更
  • 追加: "フォルダにコピー" コマンド時の進捗
  • 変更: NavPanel の全画面モード
  • 修正: 印刷オプションの "フッタ" の保存
  • 修正: "E-メール送信" コマンド
  • 修正: 巨大な RTFの読み込み.
  • 除去: "ShowStatusbarOnMedia" オプション

Version 4.0.2 (28 jun 2009)

  • 追加: フォルダのコンテキストメニュー
  • 追加: フォルダ内のすべてのファイルを開くコマンドラインパラメータ.
  • 追加: ショートカット Ctrl+Shift+Del でファイル履歴の除去.
  • 追加: OEM コードページを使用
  • 追加: オプション "その他 -- ファイルのソート方法". 隠しオプション "FileSortOrder"を廃止

Version 4.0.0 (21 Apr 2009)

  • 追加: プラグインの自動インストール(Pluginst.inf ファイルを使用).
  • 追加: TIFFへの完全対応 (VTiff.dll を使用)
  • アイコン: Tango 22x22.
  • 追加: Alt+左方向/右方向キーで - ページを変更(TIFF)
  • 追加: XMLファイルの検出
  • 追加: "ガター / 行番号" ダイアログのステップ設定
  • 追加: プラグインダイアログ: Del/Ins キー
  • 修正: AmpView による不正確なウィンドウ位置の保存
  • 修正: テキスト再読込時のちらつき

Version 3.9.0.2 (7 mar 2009)

  • 追加: URL/メールアドレスの強調
  • 追加: 検索オプション"複数行の正規表現"
  • 修正: 固定モード時のタブ表示
  • 修正: BE ファイルの行番号
  • 修正: ウェブ検索エラー
  • 修正: セカンドモニターのウィンドウ位置の保存

Version 3.8.4 (1 jan 2009)

  • 追加: プロ版の機能 "行番号を表示" を、フリー版でも利用可能に変更
  • 追加: コマンドラインパラメータ /Print.
  • 追加: 隠しオプション FileMoveDelay.
  • 追加: 隠しオプション StatusUrlWidth.
  • 修正: UTF-8 の検索(次へ)
  • 修正: イメージのちらつき

Version 3.8.0 (14 Oct)

  • 追加: アーカイブからのプラグインのインストール
  • 追加: インターネットモード: ウェブサイトのキャプションをタイトルに表示
  • アイコン: X-Qute 32x32.

Version 3.7.3 (06 Sep)

  • 追加: オプション "その他 -- ウィンドウのタイトル".
  • 追加: オプション "その他 -- 起動時の表示モード".
  • 追加: オプション "マルチメディア -- インターネット -- オフラインモード".
  • 追加: オプション "マルチメディア -- インターネット -- 不明なファイル形を開く" (隠しオプション WebAcceptAllFiles を廃止).
  • 追加: マイナーチェンジ: 前回最後に使用していたタブを保存
  • 修正: 選択テキスト(UTF8)の検索
  • 言語: ハンガリー語, ヘブライ語, ベトナム語.

Version 3.7.1 (31 Aug)

  • 追加: オプション 指定行までの最大カウント数
  • 変更: 行番号の右側の調整
  • 修正: 隠し属性ファイルの表示

Version 3.7.0 (27 Aug)

  • プログラム名を短く変更
  • 追加: 行番号: "テキスト -- ガター(溝) & 行番号を表示" オプション(プロ版のみ)
  • 追加: オプション "その他 -- 最後に保存したフォルダ" にチェックで "別名で保存"時にそのフォルダに保存します。
  • 変更: フォント設定を ini キーの別の場所に保存
  • コマンドライン: ナビゲーションパネルで選択したフォルダを開く(プロ版のみ)
  • 修正: テキストで Ctrl-R を押した時の問題点

Version 3.6.0 (11 Jun)

  • 追加: "指定行に移動"
  • 追加: ANI, CUR への対応
  • 追加: ツールバーコマンド "ViewModeMenu" (デフォルトで ViewMode1...ViewMode8 ヘ置換).
  • 追加: ステータスバー:
    • 起動時にファイルを表示 ( 200 ファイルまで)
    • インターネットモード時にリンクを表示
  • 追加: "ファイル名をコピー" コマンド
  • 追加: ファイル名のアルファベットでのソート(前ヘ/次へ コマンド).
  • 修正: Tailing の問題点

Version 3.4.0 (16 Apr)

  • 追加: 非正方形アイコンへの対応。32x32 のツールアイコンの読み込み
  • 追加: "表示 -- メディア -- 繰り返し再生" コマンド
  • 追加: "表示 -- メディア -- ウィンドウをイメージに合わせる" をフリー版でも有効に変更
  • 追加: "編集 -- 貼り付け" コマンド (テキスト/ビットマップのみ有効)
  • 追加: "ファイル -- E-メールで送信" コマンド
  • 追加: オプションダイアログの変更
  • 追加: ショートカット名の翻訳
  • 修正: プラグイン使用時の Del ボタンの動作
  • インストーラ: "すべてのユーザ" を使用
  • アイコン: Clo 29x29.
  • ヘルプ: FAQ Q10.

Version 3.3.0 (04 Apr 2008):

  • 追加: 対応する画像形式 JP2, JPC, PNM, RAS, MIS.
  • 追加: "EXIF 情報を表示"コマンドを、フリー版でも可能に変更
  • 追加: 正規表現検索をフリー版でも可能に変更
  • 修正: IJL グレースケールイメージの読み込み
  • 追加: .txt ファイルを保存する時のアイコンテンプレート
  • アイコン: Clo 24x24, 32x32.

Version 3.2.0 (19 Jan 2008):

  • 追加: グラフィック:
    • すべての JPEGへの対応 (ijl15.dll).
    • すべての PNGへの対応 (w. alpha channel).
    • プロバージョン: "表示 -- マルチメディア -- EXIF 情報の表示".
    • いくつかのグラフィック形式を ステータスバーに BPP表示.
  • 追加: オプション "一般 -- アイコン".
  • 追加: 検索の進捗ウィンドウのアルファブレンド処理(Win2K).
  • ヘルプ: 目次 "アイコンのカスタム", "プラグインの使用方法".
  • インストーラ: インストーラのアップデート, "プログラムの追加/除去" アイテムを追加.
  • 修正: 正規表現の複数行オプションを無効化
  • 修正: 'Alt'キーを押した時のダイアログの動作(Vista).

Version 3.1.0 (23 Feb 2008):

  • 追加: 検索:
    • オプション "テキスト -- 検索テキストを選択状態で示す".
    • オプション "テキスト -- エラーメッセージの代わりにビープ音を使用".
    • オプション "その他 -- 検索履歴の保存".
  • 追加: 印刷関連:
    • イメージのプレビューダイアログに ATPrintPreview 1.3 を使用.
    • "ページ設定" ダイアログへで余白の入力を許可
    • テキスト: ページ番号を印刷可能に
    • テキスト: 印刷ダイアログでのページ範囲
  • 追加: マルチメディアモードの "MCI" を戻しました。
  • 追加: テキストモード: メモ帳のマイナー機能: ファイルに合わせてリサイズ
  • 追加: 隠しオプション リネーム/削除.
  • 修正: テキストモード: 垂直スクロールバーが、いくつかのファイル上で表示されない不具合
  • 修正: "再読み込み" コマンドで、ファイルが削除されていた場合は、閉じる用に修正
  • 修正: 検索文字列を先頭のスペース無しで保存可能に修正

Version 3.0.0 (25 Jan 2008):

  • PROバージョン使用ユーザへの注意: ライセンスの種類は、バージョン情報ダイアログに表示されます。
    もし誤ったライセンス情報が表示されている場合は、キーを更新しますので、サポートアドレスまで送信してください。
  • 変更: オプション "正規表現" 検索をプロバージョンのみに変更
  • 追加: VisualDirSize のようなフォルダプラグインへの対応
    注意:
    • フリーバージョン: プラグインを使用する時は、コマンドからフォルダパスを手動で入力して登録します;
    • プロバージョン: プラグインを使用する時は、ナビゲーションパネルのリストをクリックして登録します;
    • プラグインの殆どのファイルコマンドは、初期状態では無効になっています。
  • 追加: 検索機能:
    • "検索" ダイアログの作り直し,オプション"ソース" を追加.
    • "前方向を検索"コマンド (備考: 正規表現の使用時以外、テキストモードのみ).
    • "16進文字列" 検索オプションを変更(テキストを自動的にエンコード/デコード).
  • 追加: オプションダイアログの作り直し
  • 追加: プラグインダイアログ: プラグイン ini ファイルをボタンから編集。
  • 追加: イメージの読み込みエラーの時に、UV のメッセージボックス, を表示しないで、イメージの角にエラーテキストを表示
  • 追加: オプション イメージラベルのカラー
  • 追加: コマンドラインパラメータ "/Mode".
  • 除去: マルチメディアモード "MCI".
  • 除去: 隠しオプション "TextVariableScrollbar".
  • 修正: 表示モード変更時のエラーを発見
  • 修正: テキストモード: 折り返し使用時の不具合
  • 修正: プラグインモード: Syn, Hpg_Ed.でのクラッシュ

Version 2.8.0 (09 Dec 2007):

  • 追加: 起動の高速化
  • 追加: "移動" ダイアログの改良、"選択開始"/"選択終了" オプション
  • 修正: メッセージボックス表示後にプラグインへフォーカス

Version 2.7.0 (21 Nov 2007):

  • 追加: オプション "表示 -- テキスト -- 印刷不可文字"
  • 追加: オプション "拡張 -- 特殊OEMフォントを使用"を非チェック (Unicodeシステムデフォルト), OEM テキストの表示は、ANSIテキストと同様のフォントを使用します。
  • 追加: オプション "拡張 -- ガターを左側に表示".
  • 追加: オプション メニューコマンド "追随" の、ツールバーへの設置
  • 追加: コマンド "編集 - ファイルにコピー" (テキストモードで有効).
  • 追加: テキストモード: タブのサイズの修正 (現在、等幅フォントのみ).
  • 追加: コマンドラインパラメータでのウィンドウ位置の指定
  • 修正: インターネットモード時のメモリリーク
  • 修正: プラグインダイアログを閉じた時のエラー
  • 修正: オプション "'Alt'キーをメニューのショートカットキーに付加" が、機能していませんでした。

Version 2.6.0 (22 Oct 2007):

  • 追加: テキストモード: EBCDIC, KOI8, ISO, Mac エンコードは、メインメニュー内に表示されます。
    そして、追加された 40 種類のエンコードは、F8 キーを押すことで 確認することが出来ます。
    注意:
    • 灰色で表示されているエンコードは、それらに OS が対応していないことを意味しています。
    • カスタムエンコードの正規表現検索は、まだ実装されていません。
  • 追加: テキストモード: "エンコードメニュー" (F8)コマンド、"次のエンコード"、"前のエンコード"
  • 追加: テキストモード: 右クリックメニューに、"行選択"、"エンコードメニュー" コマンドを追加
  • 追加: テキストモード: ステータスバーに、現在のテキストエンコードを表示
  • 追加: テキスト/イメージ モード: マウスショートカットの拡大: 左ボタン + ホイール
  • 追加: オプション "メニューにアイコンを表示".
  • 追加: オプション "プラグインと競合しないように、メニューのショートカットに 'Alt' キーを付加する" (プラグインダイアログ)

Version 2.5.0 (28 Sep 2007):

  • 追加: 表示モードに FAR manager と同様の "Unicode/Hex"、有効にする時は、Unicodeモードを 2度呼び出してください。
  • 追加: テキストメード: KOI8-R コードページに対応。今後、更に対応するコードページを追加する予定です。
  • 追加: テキストモード: MSIE / Forefox の様にマウスのミドルクリックでスクロール
  • 追加: テキストモード: テキストが選択された時、検索ダイアログに選択された最初の行を入力
  • 追加: イメージモード: コマンド "表示 -- マルチメディア -- 上下反転 / 左右反転 / ネガティブに変換"
  • 追加: イメージモード: 内部のライブラリで読み込めない時に、自動的に IrfanView/XnView での読み込みを実行
  • 追加: オプション "拡張 -- 最後の作業フォルダを保持"
  • 追加: "印刷プレビュー" ダイアログ: "印刷設定" ボタンと、"位置" オプション(イメージ)を追加
  • 変更: Ini ファイルの読み込み時に最適化を実行 (TMemIniFile クラスを使用)
  • 変更: "表示 -- インターネット -- オフライン"オプションを作り直し: グローバル IE オフラインフラグを使用
    このオプションにチェックを入れると、UV からはインターネットに接続しません。デフォルト値は"チェックなし"です。
  • 変更: ini 再配置機能で使用するレジストリキー名の変更 外部 "構成ファイルの再配置ツール" のアップデート
  • 修正: イメージモード: アニメーションGIF の透過設定
  • 修正: 全画面から戻った時のメニューの動作

Version 2.4.0 (23 Aug 2007):

  • 追加: IrfanView/XnView との統合 ("一般" タブ). '4' キーで、内部のライブラリと IrfanView/XnView との切替を行います
  • 追加: テキストモードの新しい印刷プロシージャ、これは テキスト/バイナリ/16進/Unicode で、異なる働きをします。 Unicode モードでの印刷は完全に完了しています
  • 変更: Pro バージョンの 試用期間を 15 日 に変更
  • 追加: コマンド "ファイル -- 印刷プレビュー" 現在、テキスト/バイナリ/16 進/Unicode モードで機能します
  • 追加: コマンド "ファイル -- プロパティ".
  • 追加: オプション "拡張 -- イメージのリサンプル(スケール)" (Win9xでは無効).
  • 追加: オプション "拡張 -- ウィンドウ位置の自動保存" と、コマンド "オプション -- ウィンドウ位置の保存 (TC Lister 同等)
  • 追加: TC 構成ファイルから リスタープラグインを追加する時に、"RedirectSection" の機能を許可する
  • 追加: 大きいイメージの表示しながらの読み込み
  • 追加: ナビゲーションパネルの、列と位置を保持
  • 追加: ユーザーツールパラメータ文字列の先頭に '?' を指定することで、パラメータを確認
  • 追加: ヘルプトピック "追加インフォメーション -- 構成ファイル".
  • 修正: コマンド "ウィンドウをイメージに合わせる"
  • 修正: インターネットモード: 終了時 Acrobat プラグインがクラッシュすることがありました。
  • 修正: イメージモード: 印刷時のコピー番号の間違い

Version 2.2.0 (25 Jul 2007):

  • 変更: これらのコマンドを、プロバージョンのみの仕様に:
    • "ファイル -- リネーム"
    • "ファイル -- フォルダにコピー"
    • "ファイル -- フォルダに移動"
    • "表示 -- マルチメディア -- ウィンドウをイメージに合わせる"
  • 追加: ロシアで使用されるウクライナの Windows へのロシアライセンスの許可
  • 追加: オプション "拡張 -- 隠しファイルを表示" (プロバージョン).
  • 追加: オプション "拡張 -- .LNK 対象の解決" (プロバージョン).
  • 追加: イメージモード: 印刷プレビューフォーム
  • 追加: イメージモード: イメージにフッタを印刷
  • 追加: テキストモード: 現在のフォントで失敗するものだけをドットで置換して表現.
  • 変更: デフォルト "全画面" コマンドのショートカットを、主要なブラウザに合わせて F11 に変更
  • 変更: 隠しオプション "TextScrollPageSize"を"TextVariableScrollbar"にリネーム, デフォルト値を 0 に変更
  • 変更: 隠しオプション "TextMaxLength" を可視化
  • 修正: オプション "ウィンドウをイメージに合わせる"をナビゲーションパネルで使えるように
  • 修正: プラグインモード: リスタープラグインでの矢印キーの動作
  • 修正: プラグインモード: IniEd プラグインでのクラッシュ
  • 修正: プラグインモード: FileInfo プラグインでの例外
  • 修正: インターネットモード: BMP ファイルが新しいウィンドウで開く

Version 2.0.0 (10 Jul 2007):

  • 変更: UV のバージョンを Free / Pro の 2 種類に変更 違いなどは、ヘルプを参照してください ("ヘルプ -- コンテンツ")
  • 追加: オプション "ナビゲーションパネルを表示" (F4), *プロバージョンのみ エクスプローラのようなブラウザが左にでて、UV のウィンドウから ファイルを直接開くことが可能になります。 備考: このパネルを無効にすると、さらに高速読み込みが可能になります。
  • 変更: 様々な履歴を別々の ini ファイルに保存: ViewerHistory.ini (Viewer.ini と同じフォルダ). 内容: ウィンドウサイズと位置、 最近使用したリスト、検索履歴、ファイルを開く時に使用したコマンド "オプション -- 拡張 -- 履歴ファイルを直接編集".
  • 追加: ヘルプを CHM 形式に変更
  • 追加: コマンド "ファイル -- リネーム", "ファイル -- フォルダにコピー", "ファイル -- フォルダに移動"
  • 追加: オプション "拡張 -- メディア -- メディアの自動再生""
  • 追加: オプション "拡張 -- メディア -- 再生回数"
  • 追加: コマンド "ヘルプ -- ウェブリンク -- プラグインをダウンロード"
  • 追加: コマンド "表示 -- マルチメディア -- 再生/一時停止"
  • 追加: コマンド "表示 -- マルチメディア -- 音量 -- アップ / ダウン / ミュート". この音量とミュートの状態は保存され、再開時に復元します
  • 追加: Vista で エクスプローラへの統合が出来ない時に警告
  • 追加: テキストモード: マウスでのテキスト領域のオートスクロール
  • 追加: テキストモード: Shift + マウスホイールで、水平スクロール (TC Lister風)
  • 追加: テキストモード: Ctrl + マウスホイールで、フォントサイズの変更
  • 追加: イメージモード: Ctrl + マウスホイールで、イメージの大きさを変更
  • 修正: 全画面状態時のステータスバー表示
Version 1.5.10.0 (26 Mar 2007):
  • 追加: テキスト/バイナリ/16 進/Unicode モード時 の検索オプション 正規表現の構文に関するヘルプボタンをダイアログに追加
  • 追加: テキストモード: 現在の行のトリプルクリック選択
  • 変更: インターネットモード: デフォルトですべての形式を許可; 変更する場合は、WebAcceptAllFiles 隠しオプションを 0 に変更してください。
  • 修正: 2 番目のモニターで作業時の"全画面" コマンドの修正
  • 追加: オプション: "イメージの透過処理"
  • 追加: 隠しオプション: TextMaxClipboardDataSizeMb
Version 1.5.9.0 (25 Feb 2007):
  • 追加: ステータスバー (任意) のファイル情報
  • 追加: オプション "メニュー表示", "ツールバー表示", "ステータスバー表示" のメインメニュー "表示 -- インターフェース" での重複
  • 追加: コマンド "オプション -- 拡張 -- 構成ファイルを直接編集("
  • 追加: コマンド "表示 -- イメージ -- ウィンドウをイメージに合わせる"
  • 追加: コマンド "表示 -- 拡大 -- 拡大/ 縮小": のテキスト、イメージ ウェブページでの操作
  • 変更: 構成ファイル (Viewer.ini) のデフォルト位置 "%AppData%\ATViewer"
  • 修正: 最後に使用していた文字セット (OEM/ANSI) を保存。(オプション"OEM 文字セットの自動検出" の無効時)
  • 追加: イメージモード: イメージを キーボード/マウスホイールでスクロール
  • 変更: RTF/UTF-8 モード: UTF-8 ファイルの署名を不必要に変更 (注意: Win9x 以下には対応していません)
  • 追加: 隠しオプション: TextMaxLength, MediaAutoAdvance
Version 1.5.8.0 (22 Jan 2007):
  • 追加: イメージの印刷
  • 追加: Total Commander 7 リスター API に対応
  • 追加: オプション "メニュー表示", "画面の中央に表示"
  • 追加: コマンド "編集 - 移動" インターネットモード時の操作
  • 追加: 起動時のファイルの位置を指定するコマンドラインのパラメータ
  • 追加: 32-bit ツールバーイメージに対応
  • 追加: 隠しオプション - FileSkipHidden
Version 1.5.7.0 (05 Jan 2007):
  • 追加: プログラムのアイコンを変更-by StickyNomad
  • 追加: コマンドを追加: オプション - ユーザーツールの設定
  • 追加: コマンドを追加: ファイル - 削除
  • 変更:テキストモード: ロックされていないファイルは削除されます - オプション 　　 "ファイルの変更後に自動的に再読み込み" が有効になっている場合は、ファイル 　を閉じます。 (注意: Win9x 以下には対応していません)
  • 追加: RTF/UTF-8 モード: URLのクリック可能に (注意: Win9x 以下には対応していません)
  • 追加: プラグインモード: プラグインで検出した文字列を適切に解析
  • 追加: 隠しオプション: FileNextMsg, WebAcceptAllFiles, ModeUndetected, ModesDisabledForDetect, SearchNoErrorMessage, SearchNoNextConfirm
  • 追加: コマンドラインのパラメータとして Filelist をViewerに渡す: 文字の接頭辞に '@' を付けます Total Commander, ツールバーボタンのプロパティのパラメータフィールドに "@%L" を入力。

Version 1.5.6.5 (18 Dec 2006):

  • 追加: Unicodeモードでの検索の実装
  • 追加: イメージモード: イメージの左上の角に、イメージのサイズを表示
  • 追加: イメージモード: イメージのマウスドラッグの有効化
  • 追加: テキストモード: マウスクリックでマーク選択を開始、 Shift+ クリックでマーク選択の終了
  • 追加: オプション"複数起動を禁止"
  • 追加: イメージの"コピー" コマンド
Version 1.5.6.0 (17 Nov 2006):
  • 追加: ツールバーの設定を可能に
  • 追加: ファイルを参照 "Readme\External Tools Configuration.html"
  • 追加: イメージのコマンド: "大きいイメージのみ合わせる", "右に回転", "左に回転", "グレイスケール"
  • 追加: インターネットモードのコマンド: "戻る", "進む"
Version 1.5.5 (03 Nov 2006):
  • 追加: コマンド "常に手前に表示", "全画面"
    注意: Windows Media Player 使用時の "全画面" コマンドには WMPの全画面 コマンドを変わりに使用します。
  • 追加: マルチメディアモード時のイメージ表示コマンド "拡大", "縮小", "オリジナルサイズ"
  • 追加: 最近使用したファイルのリスト (任意)
  • 変更: インターネットモード時に、不明なファイル形式を開く時の MSIEの"ファイルのダウンロード" ダイアログの操作
  • 修正: Windows のアジアバージョン使用時の ANSI テキスト表示の修正
Version 1.5.3 (24 Sep 2006):
  • 追加: "ファイルの自動再読み込み" と "追随" オプション (テキスト/バイナリ/16 進/Unicode モード時の、現在の作業中のみ)
  • 追加: "自動的にクリップボードにコピー" オプション (最後に操作していた時に、選択されていたテキストをコピーします) ただし、600MB のビデオクリップで Ctrl+A は押さないように注意してください。
  • 追加: オプション "境界" (表示領域の周りの境界を非表示にします)
  • 追加: オプション "16 進背景色"
  • 追加: ショートカットの設定を可能に
  • 追加: プラグインの無効化
  • 追加: "移動" ダイアログを実装
...

Version 1.3.2 (17 Jun 2006):

  • 初版リリース


クレジット

コンポーネント

Universal Viewerには、以下のコンポーネントを使用しています:

  • ATViewer, ATPrintPreview © Alexey Torgashin
  • Tnt Unicode Controls © Troy Wolbrink
  • VirtualShellTools © Jim Kueneman
  • VirtualTreeview © Mike Lischke
  • DIRegEx © Ralf Junker, The Delphi Inspiration
  • グラフィック:
    • LibTiffDelphi © AWare Systems
    • GraphicEx © Mike Lischke
    • GIFImage © Anders Melander, Finn Tolderlund
    • PNGDelphi © Gustavo Huffenbacher Daud
    • Jasper library binding for Delphi © Gabriel Corneanu
    • IJL15.dll © Intel Corp.
    • IJL add. interface © David J Taylor, Edinburgh
    • AmnAni.dll © Alexey Novosselov
  • HTML Help interface © Project JEDI
  • MiTeC EXIF Reader © Michal Mutl
  • アンパック:
    • Unzip32.dll © InfoZip project
    • Unzip code © Headcrash Industries
    • Unrar.dll © Eugene Roshal
    • RAR Component © Philippe Wechsler

アイコン

アイコン及びテーマのクレジット:

  • Clo: icons by Claude Charries.
  • X-Qute: based on Arvid Axelsson's Qute icon set for Firefox and X-Byte's theme for TC.
  • Tango: based on Tango theme.

翻訳

翻訳者のクレジットは言語ファイル(.lng)テキストに記載されています。
追加のヘルプファイルの翻訳ソースは以下にあります。 HTML Help Workshop free tool and help files sources.


コンタクト

連絡先

技術的なサポートは、E-メールを通して受けることも出来ます: support@uvviewsoft.com . メールを送る時は、スパムと区別する為に
メッセージ、件名に "Universal Viewer" を必ず含めてください。 (本文は英語 または ロシア語でお願い致します。)

また、こちらに問題点を報告することも出来ます。 Total Commander user forum (登録が必要です)